Forum Academy Marketplace Showcase Pricing Features

10 min. to build a free native iOS/Android app 2021 🔷

Hey @vini_brito and @JohnMark I searched for oauth in this thread and found this post which claims that oauth issue can be solved using the technique mentioned. Would you guys vouch for this method?

Does this work for people? Is it android specific?

I tried it for iOS but it didn’t work for me. Same error continues.

This fix is Android specific. I DO NOT KNOW HOW TO FIX IT FOR IOS.
Did you try using it on a chrome browser in ios and it didn’t work?

Maybe replacing the chrome android user agents with safari user agents might work.

I am trying on simulator in iOS while working with Xcode.

Not sure what you mean by trying on chrome browser. We are talking about native app and not browser, right? Or you mean by making chrome as default browser? I don’t know how to do that in simulator. But either way since I can’t control default browser of users, I need to find a solution without that change.

I tried putting Safari user agent by putting the useragent as “[Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.75.14 (KHTML, like Gecko) Version/7.0.3 Safari/7046A194A]” but it didn’t work.

From what I have read so far, Google is just not allowing this, unless some other things like native oauth etc are done. I am not technical enough to understand those or to figure out how to go about those.

It works perfectly on Android, can’t say why it doesn’t work on IOS.

Sorry I couldn’t help more, I’m not very technical as well.