Forum Academy Marketplace Showcase Pricing Features

2022 - 10 min. to build a free native iOS/Android app 🔷

Hi @asanhere, thanks.

When Plateform A OS contains android (forced lowercase)

@JohnMark Thank you so much for the quick response.

I have made the changes as you suggested, but it doesn’t work. Please help me with this. Though I have already routed the landing page to mobileapp page in Index.Jason file it still picks the Index page of my project.

index android

1 Like

@asanhere Try to erase the application on the phone, and re-install it. I can’t see anything else. PM so I can look at it.

Hai John,

I was reading related posts past one week. Since I have no background in coding, i got some doubts. Could you please give a solution?

I tried to create an android app and its success. In that app, i was trying to implement calling option, and image upload from camera option. both are not working by default. I refered jasonalle documentation, i realize that its possible and i have to do some more json coding to activate the native features like camera access, phone call etc.

My problem is how can i do this and where can i do this?
these native coding is should be in index.json file that we are uploading in bubble or in android studio or in bubble element?
i was confused about the element. if i want to use a button to open camera, where should i mention? or if i want to make a call while pressing a button.

could you please help me by providing an example to activate one of the native feature using bubble?

Thanks.

2 Likes

Q: “I am concerned with Apple’s accepting of the app”

A: Approval by Apple is not due to Jasonelle or BDK or any other product that uses a ‘wrapper’, but it depends on multiple factors such as making sure your app looks like an app, uses native functions whenever possible, and meets Apple’s strict security, privacy and terms standards. If your web page is at all points a visually compatible application, your application will be accepted.

Hi @bentoj72

You have to activate the features you need inside the Android Studio config file as explained here

Android Studio settings.

I’m using a simple JS call to enable or execute native functions inside Jasonelle.

Give me a few days, I’ll add to this post “how to call Jasonelle’s functions” with a handy example. It’s very simple when you have the base, but it’s very complicated otherwise! We’re not experts in javascript, and often this kind of hurdles is a ‘turn off’. :sweat_smile:

2 Likes

Thank you so much…:blush: I am waiting for that post…

Hi @JohnMark how are you? Can i ask a question, in the call the new pointer, you used above, is there a reason why the url is the version-test version rather than the live version …so you have https://your_app.bubbleapps.io/version-test/api/1.1/wf/jasonelle and i was wondering why it was not https://your_app.bubbleapps.io/api/1.1/wf/jasonelle ? also when i get to this point 55

should i leave it blank or do I insert the url https://your_app.bubbleapps.io/version-test/api/1.1/wf/jasonelle in it or is it further on i insert in when i get to xcode? Thanks

Hi @onamusia

I used version-test when testing, after I switched the link to live version (faster).

You can enter your URL (with or without version test), it’s up to you. You can change the settings in Xcode at any time. At the end, you want to point to live.

Hi @JohnMark thanks for the reply and helping me clarify that . I was having issues ,as i was using xCode 11 , and this was not helping my case , as it came up with some errors, so i was not sure what i was doing wrong. but it turns out it is a bug in xcode 11 which was at fault. Thank you for your help. I appreciate you taking the time to reply.

2 Likes

Hi @JohnMark,

My excuses for the already dumb questions :wink:

  1. I don’t find the setup file in the Android studio folder
  2. When I run the iOS setup, the setup asks a Home JSON URL, where can I find this?
  3. When I try to run the demo he gives this error
    /Users/XX/Documents/VHSS/Apps-Jasonelle/jasonette-ios-master/tools/legacy/Setup: line 24: app/Jasonette/settings.plist: No such file or directory

Opening XCode workspace. Please wait…

The file /Users/klaasvanhoeck/Documents/VHSS/Apps-Jasonelle/jasonette-ios-master/tools/legacy/app/Jasonette.xcworkspace does not exist

thanks!

Klaas

1 Like

Hi @klaas.vanhoeck1 how are you ? I just used it and I understand your questions the whole process is a bit more complex than the example above but it’s doable , as I am a beginner and I managed to get my app approved by the App Store a few minutes ago . Okay first thing , I’d suggest you should not use the setup as it doesn’t work as it doesn’t seem to find the project file or workspace file . Also you’ll need to use Xcode 10.3 or earlier ! This is very important if not you’ll go around in circles .

So what you need to do is when you unzip the file , you should find the workspace file and open it directly from there using Xcode .

Then next thing you’ll do is when you are in Xcode find the settings.plist ( it’s under the app folder ) and then make the changes to the app name there and then also change the Json url .

Now for me , I was not able to use the programme json the new way John had explained after all the help I got , so I used the old json file upload into the root folder and that worked for me .

I’m not with my computer right now , if not I would have attached screenshots but let me know if you need more explanations.

Also heads up , if you intend on testing your app on your phone and it’s iOS 13 , Xcode 10.3 doesn’t have iOS 13 , so you’ll need to copy the iOS 13 device folder from Xcode 11 into the similar path for Xcode 10.3 …it’s actually easier than it seems but this tip I’m giving you here will save you at least 4-5 hours of pulling your hair out !

All the best

4 Likes

Thanks for helping me out, I changed the json url, but got this error

Can you DM / post me a screenshot of your settings.plist options …on mine there were loads of errors on the side ( I think they are mainly recommendations ) but ignored them and they didn’t prevent the app from not running

Hi @jdav9574, @klassnenki2015 and others,

Be aware of using Xcode 10 (until the next update of Jasonelle). Always try to compile Jasonelle as soon as you install to see if everything is going well. Before pointing Jasonelle to your site, make sure the example works. Sometimes a simple name change in Xcode breaks the application during compilation.

https://your_app.bubbleapps.io/version-test/api/1.1/wf/jasonelle

I am at this exact point as well and the link doesn’t work. Could someone post what the solution was?

Hi @solidad72,

How to call API from strings.xml (Android)

and press on ‘5 replies’.
Or you can look the Slack search icon (top) and write ‘how to call API from strings.xml’.

Solution Android strings

This is what I see when I click the link you provided. There is no “5 replies” and there is no “search icon”.

The default strings file works as a I see the jasonette website appear. However, when I change it to the endpoint for bubble it says “offline”. I guess I’ll try the file approach instead of the endpoint approach.

You need to create a free Slack account.

yes try first with file approach. Endpoint has to be no auth. activated.

By the way, I was logged in. The screenshot shows that. I still don’t see what you are seeing and I don’t understand why.