Forum Academy Marketplace Showcase Pricing Features

2023 - 10 min. to build a free native iOS/Android app 🔷

Hello,

How Apple in-app purchase can be done? I’m using Jasonette to wrap and app

Thank you!

1 Like

Happy new year everyone :partying_face:

2 Likes

Hi @JohnMark would it be possible to do following?

  1. Updating the original post with updated instructions? Or maybe have another page that has updated instructions?
  2. Making the instructions in the post good for dummies like me?

For example, original post says “Download the executable files”. Now when I go to https://github.com/jasonelle/jasonette-ios I don’t know how to download executable files.

I then tried to download a file from https://github.com/jasonelle/jasonelle/releases (Got this link on https://jasonelle.com/) but then I download it, there is no “master.zip”. Or if the file that I downloaded from that link itself was the master.zip (whose name got changed with time), then I don’t see any “Setup” inside it that I can run.

You see dummies like me struggle really badly :frowning:

The thread is so long so it is difficult to go through it and see if others faced similar issue.

I just searched for “zip” in this thread and saw one post which says that I should not be using latest version of Xcode. Now that is the reason I am asking if we can have the original post updated with instructions like this. Otherwise dummies like me will never know what to do.

And I don’t know how to get older version of Xcode. And not even sure if that remark is anymore valid or not.

2 Likes

Hi @mghatiya

There’s no direct change I can do with this post but only add post. I didn’t recompiled for 2 years now. I know things are little bit different. If someone is reading this post, please send me a private message with a new update so I can publish it. :pray:

1 Like

Thanks @JohnMark for the reply. Though I am not sure if you wanted me to do something. Please let me know.

I tried to send you DM, but it says you are not accepting messages now.

1 Like

Hi @JohnMark . I made some progress using this thread (Step by Step: Convert Bubble Apps to Native Mobile Apps in 30 minutes). Still stuck though on a point I have replied in that thread.

Other than that, faced another issue which might be relevant to people of this thread. I am getting this error when I use google’s oauth in my app. When I click on “Login with google”, I get this error.

Any idea how to fix this?

2 Likes

No way to fix it, google disabled login from webkits.

1 Like

Hey @vini_brito and @JohnMark I searched for oauth in this thread and found this post which claims that oauth issue can be solved using the technique mentioned. Would you guys vouch for this method?

1 Like

Does this work for people? Is it android specific?

I tried it for iOS but it didn’t work for me. Same error continues.

1 Like

This fix is Android specific. I DO NOT KNOW HOW TO FIX IT FOR IOS.
Did you try using it on a chrome browser in ios and it didn’t work?

Maybe replacing the chrome android user agents with safari user agents might work.

1 Like

I am trying on simulator in iOS while working with Xcode.

Not sure what you mean by trying on chrome browser. We are talking about native app and not browser, right? Or you mean by making chrome as default browser? I don’t know how to do that in simulator. But either way since I can’t control default browser of users, I need to find a solution without that change.

I tried putting Safari user agent by putting the useragent as “[Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.75.14 (KHTML, like Gecko) Version/7.0.3 Safari/7046A194A]” but it didn’t work.

From what I have read so far, Google is just not allowing this, unless some other things like native oauth etc are done. I am not technical enough to understand those or to figure out how to go about those.

1 Like

It works perfectly on Android, can’t say why it doesn’t work on IOS.

Sorry I couldn’t help more, I’m not very technical as well.

1 Like

March 2022. Everyone with new idea using Jasonelle and Bubble? I’s too simple or too complex to build? Can you share your experience?

@teachamantofish , @gabriel.rozendo , @annae.novikova , @zvikag , @leonidas.petrou4
@p.daponte , @yj.johnrhee , @1david2hot , @grewal.harry , @richardosborne14

:pray:

1 Like

Hey @JohnMark ! I’m currently working with the wonderful team at @Chakor to build out a prototype with Jasonelle. It’s going great but we have a very specific use case and problem, maybe you or one of the Bubble community will have an idea to help us!

We’re adding the code to the Jasonelle to make it appear in the native sharing menu of the mobile device. So when the user is in iOS Safari, on a website they want to share the link to, they tap the share and they see the Jasonelle app in the list alongside Whatsapp etc. So far so good, the team have succeeded with that.

The problem is upon arrival, we need to tell the Jasonelle to handle the shared link somehow. My idea is to tell Jasonelle to send an HTTP POST request with the link URL to our Bubble app, as I don’t think passing info using code from the Jasonelle into the Bubble app is possible. This requires us setting the current user’s unique ID as a cookie value in the Bubble app, which the Jasonelle can read and then pass into the POST request to the Bubble app to indicate who shared what link.

I can’t find any info about building an API system into the Jasonelle, and I’m not good at coding so I’m not sure if it’s even feasible. If anyone has any advice we’d massively appreciate it. Thanks everyone!

2 Likes

Really appreciated the thread @JohnMark, but struggled to get it working till I watched the @Jon_Melo video - would recommend watching this to anyone like me who needs something more ‘idiotproof’! :slight_smile: Make your Bubble App Mobile Native - Android Studio - YouTube

1 Like

apple pay button, when I’m using the browser the button is visible, when I’m viewing the app in xcode the button is not visible. See the examples below, I’m using jasonette

Web

Xcode/app

2 Likes

Repeating groups not working on my app. Followed everything on the tutorial now got it running but repeating groups are missing
anyone had this problem??

2 Likes

Sorry just fixed this. Turned out indid not sync my live database with the dev DB.
Since I Used the live version link on the index.json file The app was not loading the version test where i had all the sample data stored.

I have to add that everything works now and its awesome. Now working on advanced features like acces to camera and location.

2 Likes

How did you manage to call out the function from within the bubble side? I installed the same version and activated the code for the camera, geo location and file uploader but cannot find a way to call these native function still

2 Likes

Did you figure it out? I am having the same issue

2 Likes