Forum Academy Marketplace Showcase Pricing Features

2023 - 10 min. to build a free native iOS/Android app 🔷

@JohnMark Did you look into why i am facing this error?

really need help here

1 Like

Hello @fuhclifffuhche Clifff,

You probably asked the javascript expert on Jasonelle Telegram (@clsource). Maybe you can hire him to fix this? Is it the same problem on both iOS and Android? Let us know your solution.

I did ask him, He doesn’t seem to know how to fix for now.

About ios, i can’t say for sure cuz I’ve not tested. I have only worked with Android.

1 Like

How would this work in practice to implement in conjunction with say @Jon_Melo 's android studio video? Thanks in advance. Think it would be a game changer for so many people and their apps if we can all work together to finally figure out how to get the file uploader to work on a wrapped app on the android app store.


Hey bud, I didn’t quite get your question.
But if you’re asking how to get that working. The zip file of “jasonette” that you download and open by Android Studio, instead of download the normal Jasonette zip, follow the link I have shared and you can download “Jasonette advanced Web view” which I think some people have added codes to it .
I have tried it and it worked.
My problem now is to get the one signal push notifications working.
I think if we work together we can do it guys.
Let’s do it


If I put the


it still indicates Error : method not allowed

Thanks for you reply anyway.

1 Like

OK thanks I’ll give it a go! I also want to implement One Signal push notifications so I’ll have a look into that once I get the file uploader working

1 Like

Please keep me updated.
I Tried to add the onesignal codes in android studios and always errors come up.
It seems easy but very frustrating.

Hello guys, so after hours of googling and help from jesonelle forum, I have been able to fix the Google aouth problem (403 useragent_disallowed)

So the problem google has with webview apps is security, that is why they block the service.
to solve that we need to assign a user agent.

  1. Update the index.jason file to the following;

    “$jason”: {
    “body”: {
    “background”: {
    “type”: “html”,
    “url”: “”,
    “options”: {
    “useragent”: “http.agent”
    “action”: {
    “type”: “$default”

  2. Replace “http.agent” with
    “Mozilla/5.0 (Linux; Android 7.0; SM-G930V Build/NRD90M) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.125 Mobile Safari/537.36”

  3. Replace the index file on your bubble app with the new one.

  4. In android studio, Search Check to make sure it contains the following lines of code.

    if (options.has(“options”)) {
    // Allows custom user agent for the webview
    if (options.getJSONObject(“options”).has(“useragent”)) {
    Log.d(“Debug”, "Using custom user agent: " + options.getJSONObject(“options”).getString(“useragent”));
    That’s it. your google oauth should work now… Happy bubbling


Thanks for this. Seems amazing and I got the simulator working on my phone.

Question: how do general users download the app? Or is this for developers only?

1 Like

Hello @hegartyjonc

You have to open an account with Apple / Play store to download the app. For developers only, you have to registered each device under Xcode/Android.

Hello @jddmrgn

Just renamed com.jasonelle for yourwebsite, ie: com.bubble


1 Like

Thanks. After some messing around the Play Store accepted the signed APK Bundle. In review before hopefully being rolled out into production. Look forward to seeing if the file uploader function now works following the efforts above. Will report back how it goes!

1 Like

I cannot get the API to work. It’s still showing Offline!. I’m tying to get android working. But this thread is the best I can find. By “do this the first time” do you mean build the app save it and open it up on your device then go back and remove “initialize” then build the app then download it on device. Also, What do you mean by “set you API in manual mode” ? Any help would be much appreciated.

@solidad72 did you ever get the api endpoint working? Stumped

did you figure it out?

Hello @serviluvapp

API EndPoint (renamed BackEnd now) is working fine. Once you finished the configuration, remove “initialize” and version-test in your URL. This is the process to configure only the API entry.


@JohnMark thank you very much for all this information.

I tried to set up an API BackEnd but it is no longer fonctionnal without “Paid plan”.
We are able to configure one, but it does not work.

I tried the urls :

  "error_class": "Unauthorized",
  "args": {
    "code": "...90054371372..."
  "message": null,
  "translation": "This application does not expose an API. Please upgrade your Bubble subscription for your API calls to run."
1 Like

Hi @AlexCottin

Bubble evolve a lot. Yes it take a paid plan now. Welcome to Bubble Lion De Jude.


1 Like

An update installation for Android and iOS build from @edtyli9 Ed. :+1:

And yes.