Forum Academy Marketplace Showcase Pricing Features

2023 - 10 min. to build a free native iOS/Android app 🔷

is jasonette still being maintained?

Hello @d9999

Jasonelle is still maintained. Ask your questions on Jasonelle forum (Telegram) about it:

2 Likes

Hello guys,
I will recommend to wait before converting your actual app to the new Bubble responsive editor if your app is complex. A lot of great stuff is waiting. :popcorn: Be prepared to pass many hours of converting and check their main post:

Congrats Bubble. :partying_face:

1 Like

Thanks a lot @JohnMark for all the content and @Jon_Melo for the videos. I was super helpful and i succeeded to have my app in submission process both for ios and Android. Really a huge thanks!

I have now a request (only with Apple so far), they are asking me to propose in-app purchase. Do you have any reco on the best way to integrate this feature? Should i use the Native apps (bdk) plugin? (Native apps (bdk) Plugin | Bubble)
It will work with Jasonelle?
Thanks a lot!

1 Like

Hello @August1 and welcome to Bubble.

Happy it works. Yes in-app can be integrated with Jasonelle (like BDK). Your best way will be contacting the Jasonelle forum on Telegram (see above). If you are using BDK, you don’t need to use Jasonelle (same engine).

1 Like

A related update! :blush:

1 Like

Hello, @JohnMark !

1 - Im trying to make a < iframe> embed video from youtube/vimeo display in FULLSCREEN in my jassonfile apk which I made following the instructions above. But Im having problems to find the “activity_main.xml” doc which i think it contains the webview part…
I found only one activity at “manifast_main” as print:

I just made a html box on bubble and added the iframe code. It is working in the aplication without the fullscreen feature as i said. Is that all that i need to make it work it with some android studio webview configs or should i make it through API using youtube API dev doc? Didnt found good tutorials so far. Lost here.

2 - This problem its getting really frustrating…struggling to change the apk icon. They say i should go to RES folder > New > Asset Img > then finish… just not working.
Some tutorial says that i should make this process in the APP, drawable, res or mipmap folder…I tried them all and nothing.

Some configs - the new icon seams to be in the right folder and everything ok.

Print 01 above - manifest doc ;
Print 02 below - launch doc;
Print 03 below - res - ic launcher;


Im running in min sdk - 22 / target and comp sdk - 29…the apk build but crashes on installing…it was working fine til change the icon. :tired_face:

Any help?

Much Thanks!!! :wink:

1 Like

Hello,

How Apple in-app purchase can be done? I’m using Jasonette to wrap and app

Thank you!

1 Like

Happy new year everyone :partying_face:

2 Likes

Hi @JohnMark would it be possible to do following?

  1. Updating the original post with updated instructions? Or maybe have another page that has updated instructions?
  2. Making the instructions in the post good for dummies like me?

For example, original post says “Download the executable files”. Now when I go to https://github.com/jasonelle/jasonette-ios I don’t know how to download executable files.

I then tried to download a file from https://github.com/jasonelle/jasonelle/releases (Got this link on https://jasonelle.com/) but then I download it, there is no “master.zip”. Or if the file that I downloaded from that link itself was the master.zip (whose name got changed with time), then I don’t see any “Setup” inside it that I can run.

You see dummies like me struggle really badly :frowning:

The thread is so long so it is difficult to go through it and see if others faced similar issue.

I just searched for “zip” in this thread and saw one post which says that I should not be using latest version of Xcode. Now that is the reason I am asking if we can have the original post updated with instructions like this. Otherwise dummies like me will never know what to do.

And I don’t know how to get older version of Xcode. And not even sure if that remark is anymore valid or not.

2 Likes

Hi @mghatiya

There’s no direct change I can do with this post but only add post. I didn’t recompiled for 2 years now. I know things are little bit different. If someone is reading this post, please send me a private message with a new update so I can publish it. :pray:

1 Like

Thanks @JohnMark for the reply. Though I am not sure if you wanted me to do something. Please let me know.

I tried to send you DM, but it says you are not accepting messages now.

1 Like

Hi @JohnMark . I made some progress using this thread (Step by Step: Convert Bubble Apps to Native Mobile Apps in 30 minutes). Still stuck though on a point I have replied in that thread.

Other than that, faced another issue which might be relevant to people of this thread. I am getting this error when I use google’s oauth in my app. When I click on “Login with google”, I get this error.

Any idea how to fix this?

2 Likes

No way to fix it, google disabled login from webkits.

1 Like

Hey @vini_brito and @JohnMark I searched for oauth in this thread and found this post which claims that oauth issue can be solved using the technique mentioned. Would you guys vouch for this method?

1 Like

Does this work for people? Is it android specific?

I tried it for iOS but it didn’t work for me. Same error continues.

1 Like

This fix is Android specific. I DO NOT KNOW HOW TO FIX IT FOR IOS.
Did you try using it on a chrome browser in ios and it didn’t work?

Maybe replacing the chrome android user agents with safari user agents might work.

1 Like

I am trying on simulator in iOS while working with Xcode.

Not sure what you mean by trying on chrome browser. We are talking about native app and not browser, right? Or you mean by making chrome as default browser? I don’t know how to do that in simulator. But either way since I can’t control default browser of users, I need to find a solution without that change.

I tried putting Safari user agent by putting the useragent as “[Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.75.14 (KHTML, like Gecko) Version/7.0.3 Safari/7046A194A]” but it didn’t work.

From what I have read so far, Google is just not allowing this, unless some other things like native oauth etc are done. I am not technical enough to understand those or to figure out how to go about those.

1 Like

It works perfectly on Android, can’t say why it doesn’t work on IOS.

Sorry I couldn’t help more, I’m not very technical as well.

1 Like

March 2022. Everyone with new idea using Jasonelle and Bubble? I’s too simple or too complex to build? Can you share your experience?

@teachamantofish , @gabriel.rozendo , @annae.novikova , @zvikag , @leonidas.petrou4
@p.daponte , @yj.johnrhee , @1david2hot , @grewal.harry , @richardosborne14

:pray:

1 Like