Adding "proper" Cloudflare to Bubble

Does anyone else use Cloudflare as a DNS? So using their DNS and having all the functions of their dashboard.

So IP blocking, Apps for Cookie etc etc

Bubble doesn’t like this much… but it doesn’t appear to break it.

I don’t use it, but what’s strange is that the issue seems to be linked to an Ip v6…

@gaimed, if I’m correct you use Cloudflare as your DNS. Could you help or provide feedback on this issue?

1 Like

Ooo, thanks. Good spot :slight_smile:

Google reports lot of issue with Cloudflare vs ipv6. There’s something to do around the config…

I could just turn ipc6 off :thinking:

And then, that works?

Ah, no. Cloudflare give you the option to turn off ipv6 but then don’t allow you to do it “for the good of the internet”.



Word back from the top…

AWS’s Ipv6 facilities are not great and we aren’t able to resolve where the Ipv6 records go in the past. This has caused issues with certificate issuance, so we left it as an error in the current iteration of the domain checking code. Basically, our certificate issuer tries to validate every A/AAAA record, and because AAAA records don’t really work inbound to our infrastructure reliable, having any AAAA records risk breaking SSL completely. The solutions for now are, unfortunately, to wait out and re-write, or potentially try some hack to make the error go away. The last solution would be for you to turn off Ipv6, as Cloudflare exposes it deliberately only as an API call (i.e. not from the dash)

So if you want to proxy your Bubble site via Cloudflare (and you might want to, as it will act as a firewall for DoS attacks) then tell Cloudflare to translate IPv4 to IPV6 … (in Network)

And ignore the error in Bubble as IPv6 is all good.



I changed my Cloudflare settings to Overwrite Headers for Pseudo IPv4 and the app works fine on the domain, but because the IPV6 error is still in showing in Bubble settings I can’t set up my email settings. Is there any way to get around this error to turn on email through the domain?

Turn the Proxy off for AAAA in Cloudflare.

Slightly different error with proxy off, but still no joy.

I got that to go away by removing proxy from everything and then removing the domain and adding it again in bubble.

Enh, it still doesn’t work. I’ll just have to deal with until I switch away from Cloudflare. Thanks for the assistance, anyway.

This topic was automatically closed after 70 days. New replies are no longer allowed.