Forum Academy Marketplace Showcase Pricing Features

Air Date/Time Picker

I’m running v3.50 of this great looking @ZeroqodeSupport plugin and having an issue with resetting the date.

No matter what I do (including using the plugin’s actions [Clear selected dates a Air Date/Time Picket v2] and/or [Set date a Air Date/Time Picker v2]) the field is always stuck with the latest input from user…

The action [Clear selected dates a Air Date/Time Picket v2] doesn’t clear anything…and often throws (console) the following error message “TypeError: Cannot read properties of undefined (reading 'clear’)”

The action [Set date a Air Date/Time Picker v2] used leaving the date empty is supposed to reset the picker to an empty value (according to plugin’s documentation) but doesn’t do the trick either…

Consequences of that picker date not being cleared / reset are:

  1. User is bemused by the reminiscence of the previous date whereas he is supposed to start from a clean slate
  2. User cannot click into the picker and cannot select a different date

The only workaround I found is to refresh the app page (browser refresh) which does “remove” the latest input value. This is not satisfactory from a user perspective.

I’ve tried it on different browsers (Chrome, Safari, Firefox) and different devices (laptop, iPad, iPhone) with the same result.

Further to that issue (initial value), once a date (single date in my case) has been selected (the picker disapears) it is not possible to edit it / change it >> clicking on it reopens the calendar pickup but it’s impossible to click any value (the calendar closes on any click). However enabling the keyboard navigation let’s the user use his keyboard to edit move within the calendar and edit the date…which is not intuitive at all and not acceptable on a mobile device

Any idea / suggestion as to how I could fix this ? Is that a known issue with this plugin ?

I’m having the same issue.
Previously adding a pause before clearing the element would work but it doesn’t work now.

I’ve also tried setting the date to “empty” after clearing the date.

I’ve literally just delt with this same issue…

The workaround (which works for me) is to use a custom event with the action ‘Clear Air Date/Time Picker’ then ‘Schedule’ that custom event to run any time the date/time picker becomes visible, with a delay of 0.01 seconds.

When I use the ‘Clear Air Date/Time Picket v2’ triggered by a ‘clear date icon’ it does clear the date…but as soon as I hover over the date picker the previous value appears again :slightly_frowning_face:

However I found a solution to my second issue (not being able to edit the date once a date has been selected) >> Uncheck the “Auto Close” option allows the user to change/edit the date

That’s pretty much what I’m doing but it’s not working for me.

What’s really weird is that it’s not affecting the date elements that I previously created elsewhere in my app. However, if I try copy / paste them, the issue still occurs.

Actually, I’ve given up with this plugin now… it seems there are way more bugs than just this one (although this issue is persisting in other circumstances… it’s strange as the element isn’t actually holding a value, it’s just displaying a previous value).

Also, conditional changes to some of the element attributes don’t work.

Time to find another solution…

1 Like

Let us know if you find a good alternative.

Hi everyone! @tbenita, @rory.mulligan, @adamhholmes

Thank you for bringing the problem you’re having to our attention. Based on our understanding, it seems like this issue is related to a popup. We believe that this is happening due to the new responsive engine, which writes the popup on the page just once. As a result, if you close it, the data will be retained when reopened.

To solve this issue, we recommend using the “Set date AirDate/TimePickerv2” function when the popup is opened and specifying the “time” you want to display. This will allow the popup to display the correct date through the plugin element. Here’s an example that might be helpful: Screenshot by Lightshot.

You can also set an empty value in Set date a Air Date/Time Picker v2 action when the popup is opened and it will just display the placeholder.

If the solution we provided did not help, we would like to kindly ask you to provide us with a video recording of your use case. This way, we can better understand the issue you are experiencing and assist you further. We are always here to help, and we appreciate your patience and cooperation in resolving this matter.


Best regards,
Zeroqode Support Team


Thanks @ZeroqodeSupport I managed to figure out that fix myself just now, so it seems to be working ok in that regard now (you’re correct, it was being used in a popup).

There also seems to be an issue with changing the ‘Type’ based on a condition…

If the initial type is ‘Range’, and you try to change it to ‘Single Date’ based on some condition, it doesn’t seem to work (you can still only select a range of dates)

But if you do it the other way round it works fine. Obviously, I can use that knowledge to make it work, but it might be worth looking into for a future fix.



Actually, it seems once a condition has been used to change the Type from Single Data to Range, no amount of further conditions can change it back to Single Date.

I can run an event to clear the element but when I close the popup and open it again, it resets to the last date selected

Date Picker Issue (2)

Hi @ZeroqodeSupport

As far as I am concerned there is no popup involved. Everything happens on my single page app as shown in this video.

I am adding family members to a family.

The ADD button triggers a WF that creates a new family member record AND clears the Date/Time picker (using ‘Clear date AirDate/Time Picker v2’) but as you can see when I try to add another family member the date picker still holds the latest input (despite being cleared before)

I’ve added a “Clear icon” (the X next to the Date picker). Clicking this icon triggers another WF using
‘Clear date AirDate/Time Picker v2’. As you can see on the video it works…as long as I don’t hover over the Date picker when the latest input reappears again no matter how many times I clear it.

Hi @adamhholmes,

Unfortunately, it’s not possible to change the “picker” type dynamically. You need to use 2 elements, in order to choose “single date” or “range”. So, one of them will allow your user to select a specific date, and the second will allow them to select a date range. Apologies for the inconvenience. :pray:

1 Like

Hi @rory.mulligan,

You need to use the “Set date AirDate/TimePickerv2” action instead of “Clear Selected Dates” as we mentioned in our previous message. Please try to use Set date AirDate/TimePicker when the popup opens and let us know how it’s going. :pray:

Hi @tbenita,
Thanks for the video. :pray:

We’ve tried to recreate your use case but unfortunately, the issue is not reproducing on our side. We’ve made a short video showing our setup and the result, here: Loom | Free Screen & Video Recording Software | Loom

In case provided example doesn’t help, can you please add our Support Team email to the list of collaborators to your application and provide us a link to your application? (here or via DM)
This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.

Best regards,
Zeroqode Support Team

Actually, even after using the Set date AirDate/Timepicker value to empty, even though initially it clears the previously selected date, it always comes back.

Although it’s not actually a useable value… it just displays in the element (i.e. in the debugger, it shows the value as empty, but it displays in the element as though it’s been selected).


I reproduced your settings as well but it still behaves like before…

Just sent you a link to my Editor and added you as a collaborator (view only)

Setting the date doesn’t work for date ranges.

From a UX perspective, it’s a bit confusing for users as the first date is predefined for them.

Date Picker Issue 2 (1)

Hello @adamhholmes, @rory.mulligan

Unfortunately, the issue you reported is not reproducing on our side. We have created a basic setup, you can check it here: Testing | Bubble Editor

Can you please also add our Support Team email to the list of collaborators to your application with edit rights and provide us a link to your application? Please also mention on which page and which scenario should be tested.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Looking to hear you soon.

Best regards,
Zeroqode Support Team

Hi @tbenita,

Let us duplicate the message here for others, it may be useful :pray:

We have added a flow that resets the picker whenever the group is opened and visible. Additionally, we found that the custom style you are using was affecting the behavior of the plugin. Unfortunately, it is not possible to use a custom style or change the style dynamically. So, as a result, it was causing this problem. Screenshot by Lightshot - Screenshot by Lightshot

To resolve this issue, we created a test page (zq2) where we removed the custom style and added the mentioned workflow. We tested everything thoroughly and it seems to be working fine now.

Please take a look and let us know how it’s going. :pray:

Best regards,
Zeroqode Support Team

1 Like