Forum Academy Marketplace Showcase Pricing Features

Ajuda! Comportamento estranho em Grupo Repetidor

Saudações, sou iniciante e e estou desenvolvendo um aplicativo (ou tentando) para gestão de estoques e contratos.
A dinâmica se inicia quando um usuário de um almoxarifado cadastra um pedido de compra de materiais que serão fornecidos através de um contrato qualquer.
Depois que o usuário cadastra este pedido (listando os materiais em um carrinho de compras e gravando no BD usando Plugin Orchestra) é possível visualizar o pedido em um popup e há um outro popup para visualizar e acompanhar a entrega deste pedido.
Pois bem, toda esta dinâmica estava funcionando perfeitamente até dois dias atrás, mas de repente, após um cadastro de pedido, o popup de visualização de entregas está apresentando comportamento estranho e a visualização está prejudicada. Os dados aparecem “piscando” (não encontro outro termo para explicar).

Acredito que as feras do Bubble identifiquem facilmente que tipo erro um iniciante como eu deve ter cometido para gerar este comportamento.
Então, se alguém puder me dar uma luz, agradeço imensamente.

é possível que tenha alguma condition no elemento que está entrando em um loop…
porderia enviar print das conditions do elemento?

Olá, obrigado pela disposição!
Na verdade são 3 grupos repetidores.
O primeiro fazendo a busca na tabela Pedido_Itens, trazendo os itens que compõem o pedido, agrupados pelo número do pedido e filtrados pelo número do lote a que pertencem no contrato:
image

image

Dentro deste RG (RG Mostra Pedido_Entrega), há outros dois RG’s:

Um deles (RG_Mostra_Itens_Contrato_Pedido) mostra os dados do pedido (itens, qtd, valor, etc.):
image

image

O outro (RG_Mostra_Itens_Contrato_Entrega) mostra a evolução da entrega deste pedido (itens entregues, qtd entregue, valor entregue, valor pendente, etc.):
image

image

Como resultado, a visualização dos dados deveria ser algo assim:

Mais uma vez, obrigado pela disposição.

pior que olhando aqui parece que o problema deve ter a ver com as configurações do responsive, e eu não sei mexer direito nesse novo responsive system (eu ainda uso o antigo…)

Mas olhando as suas buscas, eu achei que dá pra você tentar mudar o jeito que busca porque do jeito que está é BEEEEEM lento… Todo filter tende a ficar lento, group mais lento ainda. quanto maior o número de dados, mais lento.

O que você sempre tem que tentar fazer é fazer a busca direto pelo “Do a Search”, nem que você tenha que guardar o mesmo dado de novo…

a busca do RG_Mostra_Itens_Contrato_Pedido acho que seria melhor ter a busca →
Search for Pedido_Itens (Num_pedido = popup’s → add new constraint → Num_Lote = Current cell’s Num lote), sem o filter

Desculpa não poder te ajudar com o real problema… Tirei um print de quanto dá bug:

Pois é… o tal do motor responsivo! Nem me fale.
Também cogito essa hipótese e estou aqui me batendo com isso também.

De qualquer forma, agradeço demais a sugestão em relação às buscas. Vou tentar como sugeriu.
Novidades, atualizo aqui.
Obrigado.

1 Like

boa sorte! Lembrando que se não conseguir de jeito nenhum você pode pedir ajuda pro bubble, como é algo de responsive talvez eles ajudem

1 Like