🔎 Algolia Search V2.0 - Major Plugin Update from Zeroqode

Hello, @stefan.pointecker
That for these details.

We will discuss with the team if this is possible, but till now, we can advise you to use the new feature the way it is.
Since a lot of users need the trigger with even 1 letter, we should check if it is possible to rewrite this part of the plugin.

Best regards,
Zeroqode Support Team

Don’t know exactly how you have implemented it, but in my understanding, it should still trigger right away if I do not use a timeout.
If a timeout is set it should add the delay already in the first place not after the first request.

Hello, @stefan.pointecker
We are sorry for our long reply.

We are finishing one more improvement of the timeout feature on our side, so once it is ready - you can upgrade the plugin’s version and let us know your feedback about that.

Thanks for your patience.
Best regards,
Zeroqode Support Team

1 Like

Hello, @stefan.pointecker
Thanks for your time and patience.

Please note that we just finished our plugin improvement, so now the Timeout works as it should work: once you stopped typing. Please update the plugin to its latest version and give it a try.

After that, let us know your feedback about that, please.
Best regards,
Zeroqode Support Team

Thank you so much!
I tried it and it works as expected!

1 Like

Hello, @stefan.pointecker
Thanks for your feedback.

If you like our plugin, could you please rate it by going to the Plugins tab in Bubble Editor? You can find the plugin by name and give it as many stars as it deserves.
We are grateful for every user’s feedback about our products.

Thanks! :pray:
Best regards,
Zeroqode Support Team

One more question: Is there a new behaviour where there need to be a query with at least 4 characters before the search starts? Or am I missing something on my side. I tested it with the previous version 3.38.0 and I do not see this behaviour there.

Hello, @stefan.pointecker
Thanks for the question.

Actually, there weren’t any changes in that.
Can you please record a short video, where we can detect this behavior of the plugin? It would help us a lot.

Best regards,
Zeroqode Support Team

I just sent you a video in a PM.

1 Like

Hello dear @ZeroqodeSupport team,

I have subscribed to your Algolia Search V2.0 plugin. I would like to know how to create a Filtering (faceting) option menu as shown in your tutorial “Building a Barbershop using Algolia Plugin” (image below)

But you need to pay extra to see the tutorial and the plugin documentation doesn’t seem to have the information on how to do it.

Would you terribly mind to explain how to do it?

My Algolia was configured manually (not using the plugin’s Set Algolia settings action) and I have configured searchableAttributes and attributesForFaceting (image below) but I don’t know how to create a filter menu (which I suppose is a repeating Group with checkboxes for each Attributes for faceting

Many thanks

What are the key differences between this plugin and the bubble integration on pro plans?

Hi @omarzaragoza, thanks for reaching out.

Please consider checking once again the Filtering section of the plugin supporting documentation.

Regretfully, if we will display the full path on how this is implemented, it would spoil the dedicated course value.

Still, if any issue will appear during the plugin setup, please let us know.

Hi @mlewis2016, thanks for a good question.

Let us check and conclude a list, so we will share it a bit later.

Thanks for your patience and understanding.

Zeroqode Support Team

Hi @mlewis2016, thanks for your patience.

We’ve concluded a comparison table in our plugin supporting documentation, so allow us to share a screenshot of it:

Hope this helps. If there will will be any other plugin-related questions, please let us know.

Zeroqode Support Team

I can get the algolia plugin to work great on a page but when I add the same setup to my reusable header it doesn’t work. Is there something I need to differently in reusable elements that are hidden? The repeating group and input for search is in a group focus. The plugin is in the actual header itself and visible on page load.

1 Like

Hi @mack2580, thanks for your message.

To have the plugin working, please be sure to have the plugin element and input in the same group.
In case that after the change still persists, please share (here or in DM) a screencast (we recommend using the Loom tool) of all elements & workflow settings. This will allow us to identify the cause much faster.

Zeroqode Support Team

I figured it out. I forgot to show the group on input search

Hey @ZeroqodeSupport

Quick question for you in hope that you may have a quick answer :slight_smile:

Is it possible to change the grouping for a search index directly through the plugin?
It’s the Distinct and Attribute for Distinct values as shown below.

I have 3 types of searches all with different groupings and I see that some of the properties can be changed inside the “Set Algolia settings” action, the grouping/distinct options couldn’t.

Have I missed anything? If it’s not possible, is there any chance you guys could add it for us?


Hi @pork1977gm,
Thank you for your message and for using the Algolia plugin.

Let us please verify this info with the dev team and get back to you once we will have a response.

Thank you for your understanding.
Have a great day ahead. :pray:

Hello @pork1977gm,

After consulting with the team, unfortunately, the current Algolia Plugin element does not include the requested field.

However, we will explore the possibility of enhancing the Set Algolia Setting action to incorporate the feature you’ve asked for.

Rest assured, if there are any updates regarding this request, I will promptly inform you. However, please keep in mind that we are unable to provide specific timeframes as this feature request currently holds a low priority.

Thank you for your understanding, and I wish you a fantastic day ahead.

Best regards, :pray:
Zeroqode Support Team.

1 Like

Hello. I recently purchase the plugin and facing two issues.

  1. I have my “Category” setup as a Facet in Algolia. In it is an item “Woocommerce” which appears around 27K times. But in my bubble app, this nbhits value returned is almost 5-6 times to about 150K… What could be the reason?

  1. In a different scenario am trying to use the action - " Search for Facet Value"
    I’m just not able to retrieve the results of this action. I have tried placin the “Algolia Refresh” action and also setting states in the event “Algolia is loading”. In the Algolia dashboard, this action is producing the correct results as in the screenshot below, but I am just not able to store/find these results in Bubble…

Screenshot 2023-08-18 at 9.45.56 AM

Screenshot 2023-08-18 at 9.31.27 AM

Any help would be greatly appreciated :pray: :pray: