Forum Academy Marketplace Showcase Pricing Features

ALL - in categories

Guys how would I add ‘ALL’ category to be first in sort?

I have Agriculture in the list. So “Agr” comes earlier in the alphabetical sort than “All”. Any tips or tricks how to make “All” be always first in line?

Little bit of a “hack” fix but you could add a space before all so it’s " all" - - Just tested it and it seems to work for me.

1 Like

Another hack is to use ‘merged with’ …

Add an invisible Repeating Group to your page. Set its type to your category data type or option set and set its data source to categories that are not ‘ALL’, sorted as you want.

Then for the list that you wish to display, set the source to category = ALL merged with the Repeating Group’s list of categories.

1 Like

Or put a field “order” in the datatype in which you number your categories and sort the search results using this field.

3 Likes

Nah, that didn’t work for me… I’m making it Capitalized so maybe that’s why.

That’s a bit too much :smiley:

I just thought, I’ll probably just add simple text ALL and on click remove all the filter constraints. But thanks for suggestions guys :fist: