Forum Academy Marketplace Showcase Pricing Features

Amadeus API token authorization

Hello guys!
I have an app that needs to connect with Amadeus (developers.amadeus.com) to get flight information.
I am not able to correctly configure the call to get the token.
This is an example in “curl”:

curl “https://test.api.amadeus.com/v1/security/oauth2/token
-H “Content-Type: application/x-www-form-urlencoded”
-d “grant_type=client_credentials&client_id={client_id}&client_secret={client_secret}”

I’ve tried in several ways, including importing the “curl” and without success.
If anyone can help, thanks in advance.
The link below gives access to the documentation.

Cheers,

Jacques

1 Like

The same problem for me too :confused:

I have a plugin that connects to Amadeus APIs in beta, DM me if you are interested.

Hi!
I’d like to try your plugin… What I have to do to be beta user?

You need to use custom Oauth2
Will look like that:

But if @redvivi have something coming, reach him :wink:

@jacquesjr , @paulaimenes
Send me your app name in DM, so you can give it a test drive:

1 Like

I tried that too but there is the same problem :confused: Were you able to initialize the call and did it work? if yes could you share your link with us? I’m looking forward to getting this resolved.

Which error do you get?


@Jici That one

Can you share a screenshot?


@Jici

If you look at my screenshot, the body is in the Custom token body, not in another call.
You set everything in this place and after, call will be initilized using the custom token auth. You don’t need to have another call to ge the token.
Example, my first api call is https://test.api.amadeus.com/v1/safety/safety-rated-locations?latitude=[latitude]&longitude=[longitude] that is a simple one. So once everything is set in the auth part, add a call and try to initialize it.

I understood, but I tried in that way and it didn’t work on :frowning:

Continue to share screenshot of the try you make with the same settings as mine

Here is a plugin to get information for Flight Schedule:

And another ones to search for flights, fares, luggage allowance and such.

Hi @Jici , struggling with this as well :slight_smile: I followed pretty much what you have here + the Amadeus instruction (which appear to be the same), but something is still off on my end.

Can you please tell me if you did anything for this from the Amadeus authentication instruction: Each API call must contain the authorization HTTP header with the value Bearer {access_token}, where access_token is the token you have just retrieved.

If you configure the call exactly like I did, Bubble will set the header for you. You don’t have to add this. Just create call and don’t care about the auth if you set it like in my screenshot

Ok, thanks. Good news is, it now works. Curious new is that I don’t recall changing much between yesterday and today.

Oh, well. Onto other problems …

1 Like