Anchor fragment not working

I can’t seem to get the browser to jump to an element far down the page, i.e. I can’t get fragment anchors to work as documented. I enabled the ID attribute feature in Settings. I create a dummy text element and give it a tag of “jump”. Then I preview the page. I append “#jump” to the page URL but the browser (Chrome) doesn’t jump to the element. Am I doing something wrong or is this broken?

Have you tried “Scroll to an element”.
Screen Shot 2020-08-03 at 2.48.53 PM

1 Like

Thanks, I didn’t know about that. I tried it and still doesn’t work. I inspected with the debugger and perform the scroll only when the url contains “#jump” and the predicate is “yes”, but the scroll to fails. Actually, with the debugger=true it scrolls down somewhat but the element is not shown.

I don’t think you need the conditional or the page fragment identifier when using the Scroll to an element action. You can just pick any element, and it should scroll into view.

If it’s not working, check to see if there are any errors in the browser dev console.

This topic was automatically closed after 14 days. New replies are no longer allowed.