API Call Parameters Not Being Called

I’m encountering an issue where some parameter values I’m trying to set aren’t generating into the matching API call under the API connector.

For example-- on one API call the keyword parameter will generate but the store_id one does not. When replacing the store_id parameter holder in the link with a store code (3661), the API does run. The store code is only included if I type the keyword directly into the API call URL-- while it does pull the keyword parameter.

URL and screenshots are below:


Try this. Instead of including your parameters in the body, you want them in the URI itself. To do that, you need to enclose the parameter name in the URI in , as in ?keyword=[keyword].

That will then open up the Bubble-friendly input for you to replace the value with something else.

Had tried that but then it didn’t even pull the keyword. Guessing it’s a bug at this point?

Replace the question mark between parameters by &
Should be ?store_id=[store_id]&keyword=[keyword]
Remove the last ?

Made that change but still getting the error.

Did you tried without [] around value?
Also… can you provide API Doc link?