Forum Academy Marketplace Showcase Pricing Features

API connector shows data when initializing but not in app

Hi everybody,

In my app I’m using the external API connector, which up until today has worked flawlessly. Today however some of the api calls returned (empty) data in the app. While when I (re)initialize the call it does show the correct data.

This is the data that should show up, but when previewing the app all of the sudden the data is not passed correctly and shows up like this:


The first case shows the “contract” which is completely empty. The last case shows the “matchings”, where some nested entries show up correctly but some nested entries show up as (empty).

Has anyone ever encountered this problem? I tried to enforce ‘utf-8’ encoding in the api but it made no difference. I tried from different pc’s and different browsers with cleared cache but nothing helped. Everything worked yesterday.

Thanks in advance!

I am seeing exact same issues with my api connector.

One of the two entries not coming through got fixed after a few hours yesterday, but the other one still fails to correctly load.

Okay, I found a kind of fix. I just removed the entire api call and made a new one. Luckily this call wasn’t embedded in the app to much so I didn’t have to fix much within the app but it’s not the best solution.

1 Like

:nauseated_face: yikes