API endpoints in deployment to Live problem

I hope someone with experience can advise on this:

  • I recently made for first deployment to Live and it messed up my APIs.
  • As part of going to live I added a domain, which according to Bubble is working fine.
  • I also updated permissions, but have confirmed the API options are correct for the data tables that I am working with.
  • I realised that in some of my APIs I needed to change the API webhook endpoints on the other services… which I did but they still don’t run properly.

The API Data is correctly enabled and unchanged since I deployed to live.

The specific API that is giving me a problem is esignatures.io. There, the API webhook endpoint is https://[app domain]/api/1.1/wf/esignatures.

In Bubble, the Public API endpoint show as https://[app domain]/api/1.1/wf and obj

In Bubble, Enable Data API is checked for the data tables I need for the API

In Bubble, the API connector initialises fine.

When I trigger the API, I get and HTTP 400 error and the API is triggered but the data is not received by esignature.io… it just shows as null.

The workflow was unchanged from the functioning test-version.

Any help is appreviated.

@TekaTeki usually the issues with APIs is when we need to update the URL (from test version to live version) or when we forget to remove the “/initialise” from it.

Is it possible to post some screenshots?

Thanks for the offer to help @lucas.moura - I am embarrassed to say that this seemingly had nothing to do with the API, permissions or publish to live… it was related to esignature.io’s aversion to HTML in the JSON (even html:jsonsafe), which was in some text on a hyperlink. Once I removed that text everything was fine, so it was just a coincidence that the record with bad data was the one that I sent after going live :slight_smile:

1 Like