API with url encoded client error

Hi, I have set up an API call for sandbox and included all headers and paameters but keeps getting an error message. Any knows what it is I am missing please help.

Here I have integrated the shared headers and the token to be used for all my calls.
I added the token just in case it is not being handled directly. Keep in mind I get the same error with or without the token.

This is my first call to the api. I have integrated it as so.

This is the error i keep getting.

I have checked and rechecked the client id and client secret and encoded them to base64 for the basic authorization but to no avail.

Any help will be much appreciated. Thank you

Here’s how you should set the API auth for Dwolla client credentials


And how I’ve set a customer Receive only call

Heey Jici,

I tried that still getting a similar error. Unless there is something else i need to do in the UI.

Are you sure you have encoded your sandbox key:secret correctly in base 64?

i used the postman encoded base 64 since it worked perfectly there. you have another suggestion please

Can you share what you have actually?

FInally went through. I followed your screenshot. Turns out you must input the headers within the calls and make them private, otherwise it does not accept shared headers for every single call. Thanks so much Jici

1 Like

This call dont return any response for the ID of the customer created, we should make another api call to GET retrieve the customer id ?

The ID / link to the created customer is in the header… (strange way to do thing, but this is how Dwolla work).

Enable headers parsing

1 Like

@Jici thank you, that works, but im trying using the same authorization for GET calls and the token is always invalid, should be something different ?

Can you share your settings?

The auth part seem fine. You need to complete the customers part now.
Try to test your auth using a simple API endpoint like: https://api.dwolla.com/business-classifications