API workflow - API workflow request data

Hi Everyone, new to bubble and setting up my first API workflow.

Would really appreciate any help as I am well and truly stuck on one item.

I am trying to setup excel Zeroqode - Create and Manage Spreadsheets plugin on my page. When i analyse the editor for the plugin for create a new sheet…the request data’s body stingifiedData field is present. I have setup the plugin in my app essentially just like the example editor however when i input “Request Data’s…” no item for "body stingifiedData is coming up. Where does body stingifiedData come from and how come it isn’t appearing in my list of options?

many thanks,
Michael

image

Really struggling to get this to work. If anyone can assist that’d be appreciated

Any thoughts?

Really need assistance guys thanks

Hey Michael,

What you probably need to do is this:

  1. Set up the backend workflow like the plugin- app:

  1. Then click “Detect data”

  1. That will result in a popup that looks like the image below. Copy the red text (url) from the popup (and not this screenshot since this is the url for my app).

  1. Open your app in a second browser window and create a workflow with the post sheet data action from the plugin and paste that url in the field Endpoint.

image

  1. Run the workflow mentioned above at step 4 containing the action (through f.i. clicking a button which triggers the workflow).

  2. Go back to the other browser window with the backend workflow open (step 1 -3), this window should now show a popup like the pic below including “stingifiedData”:

  1. Now you can create the action to create a new sheet with “stingified” data in the backend workflow created at step 1 - 3.

Note: In step 1 the screenshot show that the option “This workflow can be run without authentication” is activated, this you should not do in general, because of potential security issues.

Thanks so much for the assistance gerbertdelangen you were spot on with the advice however the current version of zeroqode app isn’t generating the data it requires and is shown on the demo editor.

My data is now being detected I’m just not getting the input data detected that I require to load the data then properly in the spreadsheet.

Really frustrating. This is the second time I’ve purchased a faulty app from zeroqode.

Ah, then its broken it seems. Probably it is best to tag Zeroqode (@ZeroqodeSupport or @ZeroqodeTeam ). You can also post the question on their forum.

Thanks @gerbertdelangen

@ZeroqodeSupport
@ZeroqodeTeam
Could you please assist with an update for the following “Create and Manage Spreadsheets”" plugin. Requiring the plugin to complete my construction project management app.

1 Like

Hello, @michael.s.disalvo
Thanks for using our plugin.

Please find the response to your request in this thread on our Zeroqode Forum:

Best regards,
Zeroqode Support Team