Automatically assign a thing to User from a joined table

I’m having a little bit of trouble with a small item.

I have two tables - Users and UserTier. The Users table contains all of the basic info for a user, including a “joined” field that has a thing from UserTier. I have named the field “payment”

The UserTier table corresponds the the various payment tiers for the app (ie Free tier, Price 1, Price 2, etc).

What I would like to do is automatically add a specific TierType from the UserTiers table to a User’s “payment” field immediately upon signing up. The way I have tried to do this is with a workflow that has a first step of Sign-up User, second step of Make Changes to User, then third step of navigating to the first page the user should see when signing up.

It seems like I’ve gotten the logic incorrect here, as the payment field is still empty after users sign in. Can someone give me a nudge in the right direction of where I’ve gone wrong?


Sometimes writing things out can help! :slight_smile:

I was able to get this to work by changing two things. First, instead of searching on a text field on the UserTier thing (TierType), I searched on Tier. Tier is defined as a number.

I also added an “only when” condition. So now this triggers only when the current user’s creation date is not empty.

So now my question is why was I having issues with making change by using a text field? Do I always need to search via a numerical value - in which case does that mean I always need to have an numeric id field for every thing?

Hi there,

Your first method should have worked too. There isn’t any kind of restriction on the field type in the way that it’s leading you to believe. Did you check to see you had a UserTier record where TierType = Free?

Strange. Any ideas on why my first attempt didn’t work are also welcomed.

See the full table here:

It didn’t work when I tried with quotes, double or single. I can live with my workaround, as it doesn’t compromise good data architecture.

Remove the quotes. Whatever value you type in to the search constraint should match the value in the database exactly. The quotes aren’t necessary here to define a text string. This is true everywhere regarding values - no need to put things in quotes, unless of course, the quotes are a part of the value itself.