Forum Academy Marketplace Showcase Pricing Features

☁️ AWS File Uploader No File Size Limit- New Plugin from Zeroqode

Hello, @reallyreallywant.app
Thanks for these details. They are really useful :pray:

We propose you upgrade the plugin to the latest version (1.84.0) and give it a try on the test page firstly.
For high verification accuracy, we propose you remove the previous plugin elements and place a new one on the page.

With the new plugin version, the rotation of the image was never reproduced :pray: :slightly_smiling_face:

Hope it will be helpful for you.
Best regards,
Zeroqode Support team

Hello, I’m getting a “InvalidAccessKeyId” error. I’m pretty sure the settings are as per the documenation. How can I fix this? Thx

Hello @ZeroqodeSupport

I’m sorry to say that it’s back to what happened on version 1.82.0. (I have nothing but the element plugin - I’ve deleted the old one and replaced it when I upgraded to 1.84.0)

I could upload the new screens, but it’s really the same as the issues I had on 1.82.0

Hello, @henry.m
Thanks for reaching out and sorry to hear about this trouble.

The most probable reason for this issue - incorrect configuration of your AWS Bucket. Also, a really important step is to include all the information in the Plugin’s Tab:

In order to investigate your issue, please provide us with the next details:

  • Screenshot of the error from the browser console;
  • Screenshots of your current plugin settings.

Looking to hearing from you soon.
Best regards,
Zeroqode Support Team

Hello, @reallyreallywant.app
Sorry to hear that :pray:

We need to let you know that the plugin uses the metatags of the images. So, in case your device removes the metatags from the image or influences them, the photo can be uploaded with the wrong rotation.
However, this rotation will be considered a normal one.

We have tested the plugin on a huge amount of devices ( on the Samsung galaxy s7 as well) and this issue wasn’t reproduced.
After carefully analyzing the issue, was defined that this occurs because of the removing metatags and it depends only on the device. So, it can not be regulated by the plugin, unfortunately :pray:

We are sorry for this inconvenience.
Best regards,
Zeroqode Support Team

Thanks for the effort! (My phone is s8 though)

1 Like

Hello, @reallyreallywant.app
We are sorry for this inconvenience.

We noted the Samsung galaxy s7 model for the reason that these models are pretty similar in inner structure and we were able to test it immediately after receiving your details.

Unfortunately, we are unable to check this behavior due to its grounds :pray:

We apologize for this situation.
Best regards,
Zeroqode Support Team

1 Like

Hello @ZeroqodeSupport

Thanks again for your support. I’m having a new issue: Bubble doesn’t read uploaded files when the original file has spaces in its name.

The url saved in bubble replaces spaces with “%20” but the final URL in my s3 replaces spaces with “%2520”. And Bubble can’t read the image with “%20”.

see below


Screenshot 2022-01-14 at 17.26.02

Thanks for this amazing plugin! @ZeroqodeSupport

Unfortunately, it seems to be interacting with my app very strangely.

Even though the element is hidden, when the File Uploader element is inserted into any page (group as I’m building a single page app) it seems to shift a lot of the objects around even on other pages (visible groups) where the plugin has not been inserted.

For example, the plugin lives on this page:

and that particular group looks fine. Also, that particular group is hidden whenever I click to another ‘page’ and everything is set to collapse correctly. This has been tested and been in use for weeks.

Yet, now with the aws file uploader element on the page, all my other pages look wonky…

The menu, for example, is shifted…

Nothing fits on this repeating group and the icons above it are out of place…

When I remove the File Uploader element (and keep all the groups and elements that contain it / are associated with it) my app looks normal again.

This is the same page after deleting the File Uploader element…

’Hiding’ the element with ‘collapse when hidden’ does not work.

Here’s a link into the preview for inspection purpose:

I really love the functionality of this app. I hope this can be resolved.

I’m able to insert ‘FileUploaderNoGUI’ without problem, but the added functionality of the standard ‘File Uploader’ element is very important to me.

Thank you!

Hello, @reallyreallywant.app

Please allow me to mention that currently, our plugin encodes the title of the files, which contain the special characters: - _ . ! ~ * ’ ( ) and spaces sometimes. Unfortunately, the encoding of such files is the only way for being defined by the AWS bucket.
In order to prevent the download from being canceled, all invalid characters are replaced by “%”.

The plugin returns you not the name of the file from the bucket, but the original name of the file.
Please check this documentation in case of necessity: encodeURIComponent() - JavaScript | MDN

Please let us point here that currently, we are working on the improvement of this feature and reviewing the option for avoiding the % symbols even with the special characters in the title.

We will notify all our users about this feature immediately after finishing :pray: :partying_face:

Best regards,
Zeroqode Support Team

Hello, @Tyler1
Thanks for reaching out and for your appreciation.

Allow us to mention that the described issue is pretty confusing and our team met it for the first time.
Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application? This will allow us to check your settings and run some tests to check the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,
Zeroqode Support Team

Thanks for the explanation!

I’ve added a :findandreplace [%20] for [%2520] and it works for spaces. I haven’t tried for other special characters though.

In the next update, if my :findandreplace [%20] for [%2520] should be delete, can you please notify me to delete it when I’ll do the update? Thanks a lot!

1 Like

Thank you for the quick response.

I have added that email as a collaborator and I am excited to get this fixed.

To help you find the appropriate elements and problems sooner I’ll briefly describe my apps organization.

In the elements tree all of my ‘pages’ are organized on the page 'single_page_pro" in this ‘Group Content’ group.

The page I am trying to add the ‘AWS Uploader’ to is ‘Group Upload Draft’. But, to accurately see the effects I am describing, you’ll want to show the ‘Floating Group Menu’ and ‘Group Placeholder Menu’ shown here:

(You’ll have 4 group shown; ‘Floating Group Menu’, ‘Group Placeholder Menu’, ‘Group Content’, and the ‘Group Upload Draft’ subgroup within ‘Group Content’)

To help you identify the problem…

  1. Before adding the ‘File Uploader’ element, preview the app and take note of how the menu and ‘projects’ tab appear. (run as User ‘[email protected]’ in the dev database to see the best results)

  2. Back in the editor, add the ‘File Uploader’ element anywhere in the ‘Group Upload Draft’ page

  3. Refresh the app preview and notice that…
    a. the menu now has a scroll bar and appears shifted to the left
    b. many elements in the ‘Projects’ tab are now misaligned and sizing is very messy
    c. other elements on other pages are also misaligned and messy

I hope that the detail provided helps you to identify the problem quickly and find a solution without too much inconvenience to you.

I absolutely appreciate your help with this, thank you!

Hello,
I have installed the AWS uploader plugin. The scenario I am facing is:

upload files, using the uploader
the files are uploaded to my S3 bucket, but prior to uploading, theres no way for me to see the list of files or to delete/ deselect some files… unless I choose to have the preview mode on.
Since I upload large number of files and since these are not Image files, I really dont need a preview, but I need to see the file name and size, so that I can decide whether to include in the upload or delete some of the files.
Currently, theres no visual clue on whats happening with the uploader. If I need to see, then I have to create a workflow and save the files (when uploader is finished).
thats not very convenient.
Again, in the DB, it returns "all the file names: as one field, I need to see one file name at at time.
please see image sample image below


Please let me know how I can view each file name and then be able to delete before uploading to S3 or before saving to a DB.
Thanks

I have the same issue.
Previously I was using Bubbles native storage and I used ZQ multi file uploader (not the AWS uploader but the one that uploads to Bubble)}- there was no issue in uploading/downloading.
Now I switched over to AWS S3 storage and tried to use the AWS file uploader.
It uploads fine, the real issue is in downloading files with special characters/ empty spaces… This was not an issue when i used bubbles native S3 storage, even the I used file names with spaces, but did not have an issue in downloading.
so I think its not S3 or Bubble, but the way the file uploader is encoding file names.
Please resolve this critical issue so that the uploader can be useful.
thanks

@levon @ZeroqodeSupport
Hello,
I refer to ZQ AWS Uploader plugin:
The documentation mentions the element properties
Show remove/cancel button - checkbox; if checked, the Remove/Cancel button will appear for each of the uploaded files, so you can remove them-
even though I enabled it, I dont see this in my app

  • Remove button caption - text that will be displayed on the Remove button
    Cancel button caption - text that will be displayed on the Cancel button
    even though I enabled it, I dont see this in my app

I tried un-installing and installing the plugin again, but of no result
Is anyone else facing this issue?
Please let me know if I am missing something, Thanks