☁️ AWS File Uploader No File Size Limit- New Plugin from Zeroqode

Hello! I have the latest update of the plugin, but it seems the action “delete files backend” causes my backend workflows to not work if they contain this action.

Has anyone else had trouble with this?

2 Likes

Hello @teamprogresscomplete, :wave:

Thank you for reaching out and letting us know about the issue you’re encountering. To better assist you, could you please provide us with more details about your use case? Specifically, we would like to understand:

  • The exact steps you are taking when the issue occurs.
  • Any error messages you’re receiving.
  • The setup of your backend workflows that include the “delete files backend” action.

With this information, we’ll be able to replicate the issue on our end and work towards a resolution. Thank you for your cooperation.

Looking forward to your response. :pray:

Best regards,
Zeroqode Support Team.

Thanks!!

Here’s a simple one I just tried:


The second action, changing the user’s name, does not activate due to the “delete files backend” action before it.

For reference, here is the “aws file” data type I am using. And it should be noted that this workflow works perfectly in the frontend. I’ve had no trouble deleting files in the frontend.

1 Like

Hello! I’ve noticed in the most recent update the “File uploader A ‘is hovered’” condition has disappeared.

Is this intentional and a permanent change?

Hello @teamprogresscomplete, :wave:

To help you more effectively, it would be great if you could share access to your app with us. This way, we can directly investigate the workflow. Please add our support email, support@zeroqode.com, as a collaborator to your app. You can ignore any warnings about plan restrictions; our support email can be added as a collaborator even if your app is on the Free plan. Once you’ve added us, please let us know the name of the page where you’re experiencing this issue. (it would be great if you could create separate page for testing)

If sharing access to your app isn’t feasible, could you provide us with server logs that show what happens when the “delete files backend” action is triggered?


Please select these options for the logs:

About the “File uploader A ‘is hovered’” condition, could you send us screenshots or a quick Loom video showing what’s happening? This will let us understand the problem more accurately.

Thank you for your cooperation! :pray:

Best regards,
Zeroqode Support Team.

The “is hovered” condition simply is not there.


1 Like

Sure. I have added you for access. The test page is zq1_test

The page contains 2 elements:

  1. Text (the current user’s name)
  2. A button to activate the api workflow

The api workflow only has 2 actions:

  1. delete files backend
  2. change user’s name

The second workflow does not complete no matter what privacy settings I use on the API workflow.

Thanks.

1 Like

I’m using the “get all files” element action with a specific folder name input. The problem I’m having is that it is retrieving the files from the entire bucket, not just that folder. Please advise.

1 Like

Hello @teamprogresscomplete, :wave:

Thank you for providing access and detailing the setup of your test page. :pray:
We’ll collaborate with our developers to investigate both the “is hovered” condition and the workflow issue you’ve described. We’ll do our best to identify the problem and find a solution. We’ll keep you updated on our progress.

Best regards,
Zeroqode Support Team.

1 Like

Hi again @teamprogresscomplete, :wave:

We’ve checked in with our developers, and they’ve assured us that the “is hovered” condition will be reinstated in the upcoming update of the plugin. Thank you for your patience, and please stay tuned for the next release!

Best regards,
Zeroqode Support Team.

1 Like

Hello @jayborders, :wave:

Thank you for your inquiry. Please ensure that the folder name you are specifying matches exactly with the folder structure in your AWS bucket, including case sensitivity and any special characters. The folder name should be the key prefix that you want to list the files for.

If you’ve already ensured the folder name is correct and it’s still fetching files from the entire bucket, this behavior may be unexpected. As a next step, we would recommend:

  • Double-checking the folder name input for any subtle discrepancies.
  • Ensuring there are no leading or trailing spaces in the folder name input.
  • Reviewing any related settings in the plugin configuration that might affect the retrieval of files.

If after these checks the issue persists, please provide us with screenshots or a short Loom video with detailed description of your setup, so we can further investigate the matter.

Feel free to reach out if you need further assistance or if there is any more information you can share that would help us support you better. :pray:

Best regards,
Zeroqode Support Team.

I’m using the file uploader element. Is there a simple way to determine/extract the file type? It’s quite simple in the no GUI uploader, but I can’t seem to figure it out with the “regular” uploader element. Thanks

Additionally using the file uploader, in the element, section I want to filter by only allowing video and image type files to be uploaded so in ‘Accepted Files Type’, I’m inserting “video/,image/” I tested it by trying to upload a text file, and the file was successfully uploaded (when it was expected to not be accepted). I’m only allowing one file to be uploaded at a time. Please advise. Thanks

Hello @jayborders,

Thank you for reaching out!

At the moment, the GUI Uploader element doesn’t support identifying the file type of the uploaded file. We’ve passed this request to our developers for consideration. We’ll make sure to keep you posted on their decision or the addition of this feature.

Regarding your second concern, we conducted tests with settings similar to yours but found that only one file could be uploaded at a time, whether it was an image or a video. Our tests were carried out on MacOS using the Chrome browser. Even when selecting “all files” and attempting to upload a different file type, the uploader displayed the file but failed to upload it to the bucket, indicating an error due to an unacceptable file type.

Screenshots


Could you please send us screenshots showing the full settings of your uploader, and also specify the device and browser where you experienced this issue? Are you on the latest version of the plugin, if not, could you please update it and try again?

We’re keen to investigate further and replicate the scenario on our end :blush:

Best regards :sunflower:

I upgraded the plugin and it worked. But yes please keep me informed about being able to extract the file type.

Hello @jayborders,

It’s great to know that the latest update has resolved the issue with the “accepted files” function for you :blush:

Rest assured, our team will keep you updated on the developers’ decision or notify you once the feature is implemented!

Should you have any more questions or concerns, please don’t hesitate to contact us either here or by email at support@zeroqode.com.

Best regards :hibiscus:

As a heavy user of this plugin, I just want to say that zeroqode support have been absolutely brilliant. They are friendly, helpful, and address issues pretty fast. A credit to the bubble community and ecosysyem.

I’m not affiliated with zeroqode or have any reason to write this other than genuine gratitude and positivity. Thanks ZQ !

Best

2 Likes

Hello @asked111,

Thank you for your kind words :pray:. Your support is incredibly meaningful to us, motivating us to continually improve our plugins and deliver the best support possible!

Your cooperation with the issues and requests was outstanding, and we truly enjoy staying in contact with you!

Here’s to your luck and success in the coming year :raised_hands:.

Best regards :sunflower:

1 Like

Hello @jayborders,

We are pleased to announce the latest update to the AWS plugin, version 1.172.0. This update introduces two new exposed states for the GUI uploader, which return the file types of the uploaded files.

Please update the plugin and test out these new features. We are eager to hear your feedback on how everything is functioning!

Best regards :hibiscus:

Hi! Quick question.

When making use of the action “a file uploader uploading is finished” while uploading multiple files, the plugin used to activate this action after each file was uploaded in the group of files being uploaded, and now it only activates once.

Example of plugin behavior before (version 1.1670)

  1. I upload 5 files together
  2. The action “a file uploader uploading is finished” activates 5 times. Once after each file finishes uploading

Example of plugin behavior now after (version 1.1670):

  1. I upload 5 files
  2. The action “a file uploader uploading is finished” activates only once

Here is a video of it activating after uploading each file, and a screenshot of the workflow that is being activated. Version 1.167.0

It was awesome! But now the action only triggers once after uploading all the files. :frowning: Is this a bug? And if not is there a way to get this action to trigger after each individual file is uploaded like it did before?