☁️ AWS File Uploader No File Size Limit- New Plugin from Zeroqode

Hello @teamprogresscomplete,

Thank you for reaching out, and we apologize for any inconvenience this may have caused :pray:.

Previously, the event triggered after each file upload and users were able to add a conditional, but our recent tests indicate that it now triggers only after all files have been uploaded. This is due to a request from another user. We will get in contact with the developer, and as soon as more information is available, we will send you a message.

If you have any more questions in the meantime, please don’t hesitate to contact us.

Best regards :sunflower:

1 Like

Hi @teamprogresscomplete,

We apologize for any inconvenience caused by the recent change to the event trigger, which was modified based on a custom request.

To address this, our developers will introduce a new event that will trigger after each file upload, ensuring that this type of change does not recur in the future. :pray:

We will notify you as soon as the update with the new event is officially released!

Best regards :hibiscus:

Hi, I hadn’t upgraded the plugin for 2 years, just did it but all my plugin settings are gone. Access Keys and everything

is there a way I can retrieve it other than manually?

Hi @yasirzxc,

Thank you for reaching out and using our plugin! :pray:

Regarding the keys in the plugin settings, if you’ve lost the initial setup, a possible workaround could be to revert to the version you used before, where the keys were intact and copying them. Otherwise, if the excel file containing the keys is lost, you might consider deleting the old keys and creating a new set from your AWS account.

We apologize for any inconvenience this may have caused. If you have further questions or need assistance, feel free to contact us here on the forum or via email at support@zeroqode.com.

Best regards :sunflower:

1 Like

Thanks a ton, It worked, i revert back to last used version, copied the fields and paste it back to the new upgraded version.

Now the app is giving errors
image

but when I checked the demo for settings, it seems these are not mandatory for the plugin to work.

Kindly help!
Thanks.

Hi @yasirzxc,

I’m glad to hear that you managed to retrieve your keys. Happy we could assist :blush:

Regarding the issues you mentioned about the fields, while some fields are not mandatory, they are necessary for the plugin to function properly. For the crop window and rename files, try entering some data into the respective fields, click away, then delete the entered data. This should resolve the issues.

I’ve attached a screen recording here as a visual guide on how to fix this :pray:

Best regards :hibiscus:

1 Like

Hi @teamprogresscomplete,

After discussing with our developers and considering multiple use cases, we’ve decided to add an additional event that triggers after each file upload. This new feature is included in the latest plugin update - version 1.173.0.

Please update the plugin by navigating to the “Plugins” tab in your Bubble editor, selecting the plugin, and choosing the latest version.

We look forward to your feedback once you’ve had a chance to test the new functionality on your side!

Hope to hear from you soon :blush:

Best regards :sunflower:

Hi @teamprogresscomplete

We just wanted to follow up and see if you’ve had a chance to test the new version of the plugin. When you have a moment, could you please provide us with your feedback?

If you have any other questions or concerns about any of our plugins, feel free to contact our support team at support@zeroqode.com!

Best regards :sunflower:

@ZeroqodeSupport @levon
Hi,
I am having issues as below
I use the S3 uploader, ver 1.167.0, it was working fine until a few days ago, today it gives an error" Server responded with 0 code". (I am working on the laptoptop not android)
I then upgraded to the latest version 1.177.0, still I am getting an error" Server responded with 0 code".
In order to find out the issue, I created a new test sheet and added just 1 work flow with a button to set CORS, when I ran the workflow, I got an error “Plugin action Set standart Cross-origin error:
Error: Resolved credential object is not valid
at _SignatureV4S3Express.validateResolvedCredentials (/var/task/node_modules/@smithy/signature-v4/dist-cjs/index.js:561:13)
at _SignatureV4S3Express.signRequest (/var/task/node_modules/@smithy/signature-v4/dist-cjs/index.js:486:10)”.

However when i downgraded the plugin version to 1.166, the CORS error went away (this only means that there is no issue with my AWS configuration), but the s3 file uploader still throws a “server responded with 0 code”
The S3 uploader was working fine until a few days ago and I haven’t made any changes to AWS-S3 configuration either.
Now my APP has stopped working.
Would appreciate your urgent assistance to resolve these errors.

Hello @RamS,

Thank you for getting in touch with us.

We’ve also received your email and have responded to it. Please review our message and let us know if everything is clear or if you have any further questions.

Thank you once again, and have a wonderful week ahead!

Best regards,
Zeroqode Support team

this is world-class support… loads of respect for the team…

1 Like

Hello, configured aws plugin from scratch… on a test page both fileuploader and fileuploaderNOGUI are working perfect… but on my app page when I put NOgui element it works fine… but fileuploader element (need to upload multiple files) is not visible in preview… have tried many ways… like put multiple copies with different settings, copied the working element from other page but it just disappears in preview… any clue if this happened to someone else.

image
for instance I made a group for testing…
with following pluing settings… (I’m using the latest version of plugin)





image

but in the preview the element is just not there…
image

please help!

on the same page noGUI variant is working…
this same element is working perfectly fine on other pages… but on this certain app page its not working…

one more thing… I am at version 11 of bubble engine… not upgraded for long time for the fear of it affecting the current apps functionality.

1 Like

Hello @yasirzxc, :wave:

Thank you for your inquiry.

Could you please confirm if you have any other Multi File Uploader elements from Bubble on the same page? This might help us identify any potential conflicts.

Looking forward to your response.

Best regards,
Zeroqode Support Team.

Thanks for the reply… yes I have 1 multifile uploader from bubble and few of aws fileuploaders.
image

edit:

just deleted the bubble multifile uploader and now the AWS fileuploader is working… thanks for the clue… but is there a way around where these both can co exist and work.

1 Like

Hi @yasirzxc, :wave:

We are glad to hear the AWS file uploader is now working!

Our plugin uses the “Dropzone” library, which is also used in the “Multi File Uploader” element by Bubble. Unfortunately, their styling is applied globally to all elements using this library, not just their specific element on the page.

You have two solutions:

  1. Delete the Multi-File Uploader element from the page. This will prevent the styling conflict and allow our plugin to function correctly.

  2. Rewrite the styling of Dropzone in an HTML element. This is a more advanced approach and requires good knowledge of JavaScript and CSS. You will need to override the global styling applied by the Multi-File Uploader to ensure both can coexist on the same page without conflicts. Please note that this can be quite complex and might require significant adjustments to achieve the desired result.

Best regards,
Zeroqode Support Team.

1 Like