Backend workflow not passing through

Hi, I have a backend workflow to fill the data fields of a data type (“Chart Comparison Data”) that I use later as the data source of a chart. However, when the workflow is triggered, it runs and finished at the same time doing nothing (according to the logs).

As follows, some images regarding the logs data and the proccess:

Here the server logs:

Here the images of the backend workflow setup:

And here the trigger on the front-end (reusable element page) when hiting a button with the data I am passing through to the recursive workflow:

It’s been two days trying to figure it out where the problem is, trying every possible solution, looking for every piece of info on internet that may help, as well as breaking this down into smaller steps to see if then I am able to understand what is happening. For some reason I am missing, the workflow is not running, start and ends inmediately, doing nothing nor creating any new entry at the data type (chart comparison data).

Any advice or help here is more than dreamed.
Thanks a lot!

Seems like an Anonymous User is trying to run the workflow, but the checkbox ‘This workflow can be run without authentication’ is not checked. (First image shared)
This stops the API from running.
You could activate the checkbox to let unauthenticated users run the API. Alternatively, ask the user to login if doing the former is a security threat.

Hi Nico, thanks a lot for your response. Unfortunatelly I’ve done what you suggest but it keeps responding exactly the same. I’ve tried also testing to trigger it from a indentified user and the same result. Start running and finishing at the same time, with no entries on the data base.
Unfortunalty the server logs does not provide useful information (even when you tried the “zoom on the workflow”, no further info is provide that help further understand where the problem is.
I’ve tried modifying the Public API endpoints, enabling data, checking boxes here and there and triggering the workflow but again, this keeps happening.

Any advice or workaround to find out what is the problem is more than welcome. Thanks again for your response @nico.dicagno

Sorry to hear that this hasn’t fixed the issue.

If that did not work i’m not too sure what may be causing this.
Something which has been useful for me in the past is activating all the advanced filters on the log section.
This might show some extra information on the logs which hopefully might show the problem.
Share a screenshot here on the forum, and we’ll check it out.

Do you have privacy rules on Chart comp… DB? If you schedule the WF without being logged in, this can explain this issue. If you are logged in, also check privacy rules to be sure it doesn’t apply with the current user. Finally, all your fields are mandatory. Be sure to provide data for each of them.

Thanks @nico.dicagno for the follow-up reply.
Not sure if I understood your point regarding the advance filters. I checked all the boxes under advanced and run the search but it gave me the same info as before. here the image:

One thing that catches my attention is under the App Metrics, 42% of the WU comsuption from the scheduled workflow (the one it is not running) comes from a “deleted workflow action: cmlWA” which I have not idea what it means, but it sounds strage given the facts.

Thanks again for the time

Thanks for your help @Jici.

Unfortunatelly I’ve just tried what you mentioned, ignoring privacy rules, removing any privacy rule on the DB, triggering the workflow from a registered user, and it keeps happening the same.

Yesterday I´ve found this other guy here who posted a question on May this year (no reply so far), regarding exactly the same issue:

I sent him a message (reply) hoping he was able to fix it and willing to share the solution with me.
Sadly when I just tried to enter the post again, I just discover it has been removed/deleted. It seems to me it may be a bug or something regarding the bubble version. I am going to reach out to the technical bubble team to let them know.

In the meantime, If someone knows what may be happening, or has a recommendation to ask in a different channel or forum (I posted in airdev one as well), I really appreciate it.

Thanks again for your time @Jici