Bad DNS records - Error 525

I have set up my domain as app.*.com. I added the DNS records as outlined. says the A records aren’t pointing to Bubble. DNS Checker shows everything is good, but when I preview, I get Error 525, SSL Handshake Error. Until the A records are resolved, I cannot move onto the SSL portion on Bubble until the issue with the A records are resolved.

My domain is hosted with Network Solutions.

Any guidance would be greatly appreciated.

The same 525 SSL Handshake Error once I’ve moved my app to Live and paid a Personal plan in Bubble. Moreover, Bubble shows that DNS records are configured properly and everything works well. Also. there are messages to my users from time to time in popup that “we’ve detected an error and working to solve it”. By I can’t see anything as an administrator of my app.

I found a post on this forum saying the following:
Feb 2
I have, but no replies yet
edit: problem solved. There was a SSL certificate issue with my root domain

So I guess the problem is with SSL certificate on your root domain. In your case, it’s Network Solutions as I see.

Anyway, @bubble guys, please fix this or make a tutorial to solve. As I see on forum, it happens a lot with many users. I’ll try to figure it out by myself but any guidance would be helpful.


1 Like can you please specify how did you solve that problem with 525 SSL Handshake error? Many thanks!

Hi anthony!

I removed the SSL certificate I used with my IONOS contract. It worked only when I removed it.

I added SSL to my domain with Network Solutions. Are you saying removing it may be the solve?

Yep, that’s exactly what I’m saying. But I can’t say it will work 100% for you. But it might

Have you tried to file a bug report at

I have. It’s been escalated. Same with Network Solutions. It’s been quite frustrating.

Hi, I finally solved this problem on the subdomain and without removing SSL on my root domain (as it is hosted on website builder platform). I don’t know what exactly helped but here are my steps:

  1. I’ve added subdomain to Bubble and have added two A records in my domain DNS settings to the subdomain app.* as it was asked in Bubble settings.

The problem with SSL 525 Handshake Error has occurred. And workflows started working accidentally from time to time giving errors. Even on the development version of the app.

  1. I sent an email to Bubble support asking what to do and letting them know that I have an independent SSL certificate on my root domain.
  2. Right after that, I’ve removed two A records from my domain DNS settings and put one CNAME record routing to (as I’ve seen it in one of the Bubble tutorials). In Bubble settings I removed subdomain, wait for 10 minutes and then added it back.
  3. Website started to work properly, everything worked good. BUT only for one hour. In an hour, SSL 525 Handshake Error started to be shown regularly again and again.
  4. Then, I’ve got a reply on email from Bubble support. What they asked is to remove CNAME record and put back those two A records and re-connect subdomain to Bubble. It’s weird because I’ve experienced the problem even with those A records.
  5. I did it. Removed CNAME record and put back two A records. And I removed subdomain from Bubble and then put it back again.
  6. I’ve got an email from Bubble support that the problem has gone and that they see that everything works correctly. And now it works well.

So, to make a long story short, remove A records, put CNAME record pointing to (website would work but still with errors). Then, wait a few hours and remove CNAME record and put back A records. Re-connect your domain in Bubble.

That’s what helped me. Hope you will solve this problem as well and Bubble support will make some kind of step-by-step tutorial for that.


1 Like

In reading over your steps, am I literally putting

Yes, exactly that link as a CNAME record

And keep the A records as they list them, or no? I feel as if I am fighting a losing battle here. :frowning:

I believe I had missed one of your steps. The one about disconnecting then reconnecting to bubble. Will try again. Thank you!!

Thank you! Thank you! Thank you!
I now have a secured app!!! :sunglasses:

You are my hero!!!

1 Like

Thank you a lot!
I’m sorry that I didn’t reply to your previous comment, I haven’t seen notifications.
That’s great that you handle this problem.
Let’s ask @bubble to make some kind of official tutorial on how to solve it. Would be great if people don’t lose a few days trying to figure out what to do :slight_smile:

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.