Behavior Change on Selecting

I have a notification popup, and if you click on the notification it goes to the correct page. On the right I have these gold circles which you can click and it will mark it as read. I also have them on the already seen to make it so the notification goes back up to the unseen area.

This has worked well for a long time, but last few days I’ve noticed an odd behavior, and I’ve not changed anything.

Lets say the notification I’m clicking the mark as read circle is “Notification A”, and the one below it is “Notification B”.

When I click the little gold circle to mark it as read the popup window should remain open, and the notification is just moved to the read section below. Instead, it closes the popup window and takes me to Notification B’s page. As if I clicked Notification B(not the gold read button). If I go back to the list it has marked A as read, but why has the behavior changed?

I checked to make sure the button is arranged to the top, and that the workflow attached is only to change the current notification to “seen”.

I have no idea why it’s behaving this way now.

To add, this just happened to me when I clicked the gold mark-as-read button.

OK, going through the debugger it looks like the click is now going through to what’s under it. So since the gold button is in a group with the workflow instead of doing what it used to do and only clicking the top thing. It does both, and since the first one sends the notification to the unseen, it moves the next notification up so when the workflow runs as if it was clicked twice it goes to whatever notification(or Parent Group) is now there which is the Notification B. This feels like a bug to me.

They recently changed how (floating groups?) work and the how the elements are stacked. Pretty sure it was floating groups. Anyway, this is likely what you are experiencing, and you will have to adjust your system to the new version of things. Double check the recent changes Bubble has made, I just can’t recall the specifics, but I am certain this is it, and it’s not a bug.

That’s really disappointing, since I have a ton of stacked elements like this throughout my site, and no way to find them.

I find it hard to believe no one else uses elements like this. This has broke my entire app, since I have this all throughout it. Why would they make a change like this? Does anyone know how I can find these through the entire app? They don’t spit out errors they just don’t function has it used too.

Are you perhaps thinking of the recent changes to popup handling?

I would not consider this to be a nested popup, and It’s also not a floating group. It’s a simple Popup that has group and an icon. The group has a when-clicked workflow, and in that group there is an icon with a when-clicked workflow. Before when you clicked the icon it would only do the workflow for the icon, but it started to trigger first the icon workflow followed by the group’s workflow it was inside.

Here it is again in my app in a different situation that does not involve a popup. The main white group will take you to the guests profile if clicked. The Chat icon in that group will open a popup. This used to work that if you clicked the icon it would open the popup, and if you clicked anywhere else in the box it would take you to that user’s profile page. Now it does both, it starts to open popup but instantly cancels that because it takes you to their profile. Making that icon useless. This is a bad change in my opinion. Was this an intended change or a bug?
@troy.roberge @sudsy

They should work the same way the buttons work that are also within the group.

Check the z-index. Make sure your popup link is on top and not below. I’m guessing you can correct this issue pretty easily but ensuring this is sitting on top of the pile.

1 Like

Have you tried running Bubble’s debugger in step by step mode? Sounds like an issue that you can pinpoint using the debugger.

Yes, I can confirm it is arranged to the top. The group it is in has a white background, so I’m not sure it would even show. I also tried putting it inside a group to see if that would prevent the main group’s workflow from triggering, but that did not work either it just runs through the entire stack of groups doing all the workflows in order.

@ihsanzainal84, Yes, I’ve used the step-by-step debugger, and that is how I discovered that it is running through all the different workflows instead of just doing the icon’s workflow. If I click the icon it does the workflow for that, then it goes to the parent group and runs the workflow on that, and keeps going. I don’t normally have more than one workflow stacked, but just like a button you expect an icon’s workflow to be the only thing that runs, and not any workflows of the parent groups the button or icon is within.

Put your “most on top” button/icon in a group that is non clickable so it can’t click through both and activate both workflows.

If that fixes it then definitely file a bug report saying now these buttons are being clicked-through

Do you have your clickable icon in a parent that is also clickable (ie has a workflow on click)?

Yes, the icon is in a parent group that is clickable, and has a workflow. I’ve had these setup like this since I first setup the app. It’s nice because the parent group, in this case, will take you to the user profile, but I have buttons, text, and icons within that which does different things. This has always worked until recently. The buttons and text still work as expected without activating the parent group’s workflows, so this only affects the icons which no longer stop. The issue is I’ve done this throughout my app, and I have no way of finding them all to change them. Also, in situations like this I like having them work in the way they used to work. I’m not sure if this was changed on purpose, and if so why? It seemed to be working great as it was.

If text and buttons aren’t being click-though, but now icons are then definitely file a bug report because that’s not right

There is the App search tool near the deploy button, you can search by element type and at least know where your icons are.

I am so lucky I put all my icons in groups (for appearance), then those groups do the workflow… although I don’t think I have two clickable things on top of each other but still…

1 Like

Additionally I just tested with the bubble icon and it seemed to work as expected. It seems to be only effecting the “Ionic Icons” which is what I normally use. So it really does feel like a bug to me.

Secondly, how do I file a bug? I thought that is what I was doing creating this forum post. I’m not sure I have the technical expertise to make a clear bug report to people who would understand my lack of understanding.

It does sound like a bug with ionic icons.

You can file reports here

This topic was automatically closed after 14 days. New replies are no longer allowed.