Blockspring is Down

We noticed this last night and thought they’d be able to get it back up right away, but it’s still down this morning. I wanted to share this because we didn’t see any notification from them and I wouldn’t be surprised if a bunch of other Bubble apps are dependent on it. I know ours certain is.

1 Like

@sridharan.s for what it’s worth Scott I use blockspring into different instances …both seem to be functioning correctly. Is this a specific block or generic in your case?

I believe it’s an issue with their SSL. We’re not able to access our blocks. And, their homepage is down. My guess is it’s fairly widespread, but I haven’t seen any information from them so I’m only speculating.

I’m not seeing any issues with Blockspring integrations right this second. What’s strange is their status page claims 100% operational with 0 downtime. https://status.blockspring.com/ Looking at their SSL cert, it appears to be a flexible/universal SSL by Cloudflare (not registered to *.blockspring.com)

026407f602229f45010267d387dbb9a9

In the past I’ve had problems loading sites in some browsers when they rely on these types of certificates – could be local antivirus or firewall that doesn’t trust the cert, an older browser or even your ISP. Please post back if you see any changes, I am curious what the issue could be.

Are you able to view the status page with https in front? I get an error message (see below). I’m using Chrome on Windows. Their status page loads just fine for me without the https in front.

reachable for me from Germany just fine…(Win7, Chrome)

I am, yes:

Are you see that error on all devices you attempt to connect from or just the one?

Interesting. 3 devices don’t work through our wifi network. My cell phone works when I use cellular network.

We just tested 1 of our 10 blocks and it seems to be working. Can’t ping it manually, of course, though since we can’t get that page to load.

I’m in the UK and all seems to be working and accessible

Ah ha! I know what this reminded me of: I had the exact same error back in September in one of my Bubble apps. I even filed a bug report where I attached this screenshot:

5960213278f75b274294824da3670a45

This is the response from Bubble:

Hi Phillip,

Thanks for following up on this. I ran a test on the DNS records for [domain] using dnscheck.pingdom.com (see the link below) which indicates that the issue is likely due to the setup of the delegation for the subdomain ‘[subdomain]’ (see the screenshot attached). Please verify your DNS records are sound and/or check with your hosting provider that everything is working on their end. Reach out to us if you have additional questions or need help with anything.

Website Speed Test | Pingdom Tools

Best,


Nickhil Sethi
Bubble
support@bubble.is


I bet this is an error on Blockspring’s end or possibly even Cloudflare (as their DNS provider). As I recall this error went away after 4 days of the site being down for me even though Bubble could access it from their location.

2 Likes

Thanks for the insights. Seems like it’s more limited in scope than we had hypothesized. However, their site is still down for us on our network and our Bubble logs show errors from not being able to connect (so it’s not just our network connection). Their blocks seem to be back to normal now which is the important part.

We’ll keep an eye on our logs and will let you know if we see any more material outages.

@sridharan.s Scott…Just an update my end today…its down

Yeah, it’s still down for us too. Had to make changes last night to a block on a mobile phone because their site is down for us throughout our building. Kinda ridiculous since they are an infrastructure company.

@sridharan.s I agree Scott…$15 a month is a small price to pay for speed, elegance and ease… But if it’s flaky ( nothing on the iinterweb as ever hundred percent I understand that) then i’ll have to drop this and just stand up the API integrations myself…which I should have possibly done in the 1st place.

Agree. We’ve been experiencing timeouts with Blockspring for a while so we started running an experiment ourselves by hitting Blockspring with a cron job. Turns out, 4% of the time it takes Blockspring >20 seconds to respond. Additionally, we know eventually Bubble times out. From my point of view, a 20 second delay is crazy long for most of the ways we’re using Blockspring in our app and even 5 or 10 seconds isn’t acceptable. So, we’re starting to consider our options because the status quo isn’t sustainable.

1 Like