Bubble stripping utm params from URL

Hi, I’m seeing strange behavior in my app where Bubble is seemingly stripping only utm params from the URL. This loom reproduces the issue:

You can also reproduce it here:

What’s weird is it doesn’t occur with any other params sent via the querystring, only the 5 utm params:

So it’s happening for only:

  • utm_source
  • utm_medium
  • utm_content
  • utm_term
  • utm_campaign

Has anyone else seen this in their app or is mine uniquely afflicted? I’ve already gone through using the magnifying glass to find any action instances of either “go to page” or “refresh page” and set them to “send current page params” just as a precaution. Problem persists though… would welcome any help troubleshooting or confirmation that this is a Bubble system-level issue. thanks

Your link is working fine for me with all the utm_parameters remaining in the url… in both Chrome and Edge.

What browser are you using?

My guess would be it’s your browser stripping out the UTMs, rather than anything Bubble is doing, probably based on your browser privacy settings.

Does the same happen on other websites? or just your Bubble app?

Same here — working fine. Maybe clear your browser cache? Or, maybe your anti-virus software?

Brave browser is most likely the issue here.

Y’all thank you. I’m not in front of my computer but 99% sure that’s what’s going on here. Sorry for the errant post but thx for the catch :pray:t2:

so just to close the loop on this: I confirmed that indeed this issue does not occur in Firefox and Safari browsers. Interestingly enough though it DOES occur in Chrome so not just Brave browser blocking. This proves though that it’s a browser-level rewrite rule somewhere.
I removed the uBlock Origin, ExpressVPN and Newsfeed Eradicator plugins in Chrome thinking perhaps one of those was the culprit but the issue persists in Chrome. In Brave I’m able to open a private window and turn “Shields” off for my site and it now retains the UTM’s so I have what i need to continue dev. Thanks very much @adamhholmes @jgellis & @lantzgould for helping solve this head-scratcher :pray:


This topic was automatically closed after 14 days. New replies are no longer allowed.