Button with icon instead of text

Hi there!

I created a button and instead of having text on it, I assigned it a picture. It was showing the picture all fine. Then after some changes somewhere different (don’t remember where though :frowning: ) suddenly it only showed the path but not the picture anymore. Any idea why?


Any help with this, please?
I’ve noticed you are quite knowledgeable in other threads, @andrewgassen :slight_smile:

Don’t know why it’s doing that. One solution is to change the button to be a text field and then make it look like a button.


I usually do what @sridharan.s suggested. I’ve never tried the route you attempted above, but it seems weird that it used to work and didn’t. Maybe file a bug report?

1 Like

Will do that, thank you for your reply! :slight_smile:

Thank you for your reply! :slight_smile:

Then it still wouldn’t be a picture, right?
It was meant to be a grey button with a white icon. When clicked the grey turns orange, still showing the white icon.

You could also use an image or group field if you want it to be an image. Same idea. Use a different type of field but make it look like a button.

I tried with a shape, but it didn’t have the same or as easy attributes as a button. It is basically meant as a toggle really. Click=Interest added. Unclick=Interest removed from user profile. I just don’t get the toggle use and decided to go for using states with the button. Which was also easier than grouping a shape and an image together. :thinking:

The problem with the “icon looking like a button” is that I cant assign a different self uploaded image to each cell. I would need to pick the icon already before and choosing an image wouldn’t let me have a round background around it to make the image (being an icon) look like a button.

Ended up going for just shape + image on top.

but thank you! :slight_smile:

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.