Can´t Post Array Formdata values

Hello everyone, I currently have an API in which I have a formdata-type body and an array-type parameter, however when I POST a new element the API returns success, but only the first element of the array is added. I would like to know how I can add the other values.


1 Like

Hi @sistemas1
I did like this & it resolve my issue (Maybe it can help you, but its not form data)


@Jici helped me a lot to setup API’s (Maybe he can help you)

1 Like

Thanks for replying viquarahmed07, I tried in that format, but for formdata type I keep getting the same result, just adding the first element of the array that I send to the API.

Hi @sistemas1 :wave:

Just to make sure I understood…

Even when you Inicialize your API you get the same result. That is right?
You don’t get any error. The issue is that only the first element is passed in the Array.

Did you already trid to initialize you call with something like: “var1”, “var2”, “var3” ?
Separating the elements with quotes?

Hello @rpetribu :slightly_smiling_face:

I tried in this way, but got the same result, only the first element were added on.

Any doc url?

The problem may be in your endpoint…

If you use the site webhook.site to test your POST you can make sure that you are sending a list instead of a single element…

As @Jici said… any documentation will be good…