Change password

I am getting an error when using change password api. I am always getting the error saying the old password is not correct. I looked in the server logs and I am seeing the same password for the user login and the old password. Is there a known bug in the bubble change password API ?


any suggestions please

Maybe you can show a picture of your logs or workflows to give us a better idea on how to help.

My first thought is…

How can you see the passwords in the first place? Did you make up your own data type as password?

Bubble does this for you and you shouldn’t be able to see a persons password at all. Its all encrypted behind the scenes.

sorry looks like what i see is not the password but the length of the pwd characters. I have also hardcodded the old password too to send the value to the API and still get the same error. Just for testing , I used a pwd of 1 char length. here is the screenshot

What do your workflows look like? Hardcoding the password is not going to make it work. Take a screen shot of the workflows and maybe we can help you.

I am calling this workflow from Dropsource. I just supplied hardcoded pwd for old pwd for testing only since I was getting an error. Here is the screen shot of the change password workflow


I believe the option “update users credentials “ is looking for the password in bubble. If you are trying to “hard-code” a password, which I HIGHLY DO NOT recommend. It would be unsafe for your users and be more like a phishing site. You would have to just “change a thing.” The best way is to just follow how Bubble has saved the password. That is the most secure way.

I pass the pwd from dropsource through a change pwd screen. Since I was getting an error, instead of end user input, I just checked with old pwd bieng sent as hardcoded value. I did this to just remove the possibility that the input values are somehow being transformed from drosource to bubble.

I reverted to no hardcoded pwd and I get the same error.