Forum Academy Marketplace Showcase Pricing Features

Creating a thing (with a location) and setting it in same workflow not working

Hello,

I’m not sure if this is a bug or something I’m doing wrong but I’ve tried everything I can think of.

I’m trying to create “a thing” which I’m calling Market Geographies in step 1. This successfully executes because I see the new element in my data. Here is a screenshot of step 1

In step 2 is where I appear to have the problem. I attempt to set this new Market Geography as the value for “closest_FF_city” which is a variable of my existing user. For whatever reason this step does not complete successfully as part of this workflow.

Does this have something to do with the fact that Market Geography takes an address from the same user as one of it’s values?

Thoughts?

What field types are city and closest_FF_city ?

What happens if you set closest_FF_city to Current User’s customer address ?

I would have thought you would need to pull city out of “customer address” for it to be set to a city. So it looks like it might be some odd field definitions ?

  • city is an address type

  • closest_FF_city is my custom “Market_Geographies” type

My naming convention could probably use a touch up. :slight_smile:
closest_FF_city is probably more aptly named closest_FF_geography

I wouldn’t be able to set closest_FF_city to current user’s customer address because it is not an address type.

Ah, OK, got it.

So current user is not updated with the thing created in 1 ?

Odd. Instead of doing a step reference , what happens if you set it directly with a search ?

Tried your suggestion Nigel but was not able to get it to work that way either.

I’m fresh out of ideas.

Longshot … but you are using a custom event, is that an issue ?

Tried moving the workflows out of the custom event into the button itself but still had the same issue.

The issue might have something to do with these 2 errors that I can’t seem to resolve. When I clicked the top error it took me to the first “Thing to Change” but I can’t seem to figure out what is wrong with the statement. Even when I replace:

  • city is within Search for Global_Valuess:first item’s city_max_miles_radius
    with a hard value

  • city is within 50

The error persists.

If you can tell me where the error is in my code perhaps that will fix it. See below