Croppie won't open file picker?

Croppie File Picker won’t open on my main app, however it works fine on other apps in my account…

Tried creating a blank page, with just the croppie and a button with workflow “Browse Croppie” attached to it.

When I test the page with step by step debug it will work, however when I use the debugger on ‘Normal or Slow’ modes nothing happens… the Browse Croppie action gets called, but then no file picker opens.

Has anyone seen this before?

I’m confused because it works in my test app, but not in the main one - very strange.

Thanks for any help in figuring this out - this is the first strange thing I’ve encountered with Bubble.

Just to clarify Here’s a 1 minute video showing the croppie issue

I’m not sure if this is a bug, or what may be causing it…

I tried going from v1.0 to v0.7 of croppie, but the same issue is happening…

Hey Mitch :slight_smile: Can you share a link to the editor of the app where the Croppie isn’t opening? (Can PM if you prefer)

Thanks @fayewatson for the help with this!

The Browse Croppie Action to open file picker doesn’t seem to work when using the TODC Bootstrap Theme because of an issue with the ‘is pressed’ style condition. When you remove the style condition the file picker appears.


This saved some time yesterday, thanks :smile:

I just blitzed all the styles, was there are particular element that made this not work ?

Hi @NigelG - I don’t think there was a particular element - I made this as simple as possible.

Worth noting here that croppie has other issues as well with cutting off parts of the image when an image is rotated and zoomed giving unpredictable results like user profile images with the bottom 30% of the image just white. More info here: Croppie - element plugin to crop and zoom images before upload

Thanks a lot ! This post saved me some sleepless nights :grinning:
My app was working perfectly in FF and IE. In Chrome however it but would not load the browser dialog for the Croppie (except for debug step-to-step mode). Creating a custom button style without the ‘is pressed’ condition solved the issue. So the issue is still present in the latest Croppie plugin release.

Hi Mitch, how did you get croppie to work? I have it on a plain page but still can’t get it to open the file uploader