Daisy Chain Filter not working

I have a daisy chain filter that works great except for one filter option. For some strange reason, it returns partial results.
I don’t known what I’m doing wrong; I tried going through every step and comparing unique ID’s of the filtered skills and I just can’t understand why it partially works.

The Repeating Group contains a list of Employees.
The data is filtered by a Reusable Element called “Search & Filter”.

Changing the filter options will change the custom states associated with the Reusable Element and these are used to filter the Repeating Group.

Below is a rough summary of how the data types are interlinked.

The “Skills” filter will set a list of the data type “C-Skill”.
The daisy chain should search for a list of “Employees” who have an “E-Skill” (Employee Skill) containing the “C-Skill” (Company Skill).

I’ve tried using advanced filters to see if the employee list contains the list of skills.
image

I’ve also tried using advanced filters to see if the employee list intersects with the list of skills.
image

My hunch is it’s because you are trying to filter three levels deep (an employee’s e-skills’ c-skills), and Bubble can’t handle that final level in this filter.

To see if this is the case, try removing a level.
Redo the input and the filter so that it’s just doing the intersect based on the employee’s e-skills. This will tell you if it’s a problem with your filter, or with trying to go to that third level.

Hi Ed, thanks for the reply.

I finally figured it out.
My workflow to create each Employee’s skill wasn’t adding that skill to the list of skills in the “Employee” data type :man_facepalming:
I must have accidentally removed that action from the workflow.

This topic was automatically closed after 70 days. New replies are no longer allowed.