Data migration issues

I am running a data “migration” transferring a group of records (~20k rows) from one table to another. I have left the intervals empty to allow the “healthy system”. Anyhow, it is not transferring all the records. There is a conversion in the way that I know is working. Each time I run it, I get different results in the amount of records transferred and it misses records here and there. I need some help with it.

Hi @elmo.gomes, have you tried the following?

  1. Add a backend API workflow with just one parameter of type “Old data type”
  2. In that workflow do your creation of your new data type thing
  3. Then go into the Data Tab & Select the database view “All Old Datatype”
  4. Click “Bulk” (top right)
  5. Select the api workflow and hit run

Does that work for you?

Tip: If you only want to migrate a selection of your old data table:

  • Add conditions on the API workflow
  • Add conditions on the Database view

Hi jukoen, thx for this, but the issue was more due to the asynchronous approach of Bubble, and some backend calls were being lose somehow. I have used the recurrent workflow technique, where the workflow is triggered for the first record and it then schedules a workflow for the second, and son on. In this way, i was able to ensure all records were transferred. This was suggested by the bubbler Vini Pereira.