Data not saving

That makes sense but the previous thing i said i went through what would most likely be the issue and tried each one and each time everything worked compared to last time EXCEPT i got rid of the reset relevant inputs. So right now everything works totally fine but what doesnt make sense to me is I’ve gotten rid of that reset inputs before and it didn’t use to work before either?? So Idk how it just works now??

For this particular setup, Reset Relevant Inputs wouldn’t be necessary, as you’re done with the page…additionally ‘Reset’ puts the inputs back into the state they were in before, or in this case, blank.

1 Like

Yea it just works now so now the trick is to NOT touch it while it sits on the ledge of breaking. Anyways thanks for you help you wouldn’t believe how much this means!

1 Like

Can someone help me, I have no clue how to rotate an element?

Oh man…. Sometimes it works and sometimes it just doesnt! About to give up at this point to be honest. Ill create a dog and sometimes it’ll create no problem and then sometimes it wont at all!

The only other thing I notice is the use of ‘this input should not be empty’ on some but not all of the inputs. Just to narrow down possible culprits, could you clear out those as well?

Reading about it in the manual:

I have those inputs yes, but on some certain inputs they only show up if another input has been checked, so wouldn’t that mean they only have to be not empty IF its even able to be clicked on? I can try that though still.

I think you just diagnosed the issue!! If you have that condition on hidden inputs, than those inputs aren’t getting selected! For now turn off ALL ‘should not be empty’ settings. Once we determine that setting was the cause, than you can start re-thinking how to introduce those conditions back. But this one feels like the most solid theory yet.

Oh man i wish, just tried it out i removed all of the should not be empty requirements and still no luck!!

I booked a 1on1 session next Monday with a bubble coach to really help diagnose this. If i can figure this out before then awesome but i wanted something more concrete in case I can’t.

1 Like

A few more things to try - I also noticed as we’ve narrowed things down you’ve re-introduced them back. I find when troubleshooting it’s best to narrow things and not start re-introducing them until you know for sure what the cause was. Otherwise, it’s just more variables.

Ok in step 3, for the popup, try adding an ‘Only When’ with:


Current Users Listed Dogs Contains (Result of Step 1)

And then do the same thing on Step 4.

Yea man idk at this point, tried this and many many more things and still nothing. I even paid for a coaching session and still nothing. I submitted a bug report.

I found a very similar post to yours from early 2023, with almost the same set of circumstances - records were getting created as entirely blank. The one thing that I noticed is that both your form and their form had a lot of Upload areas. I do think this is indeed a bug, and I would point Support to this post as well:

@marketing11 did you ever figure out this issue with your app?

I figured, i did submit a request and they responded immediately with a video that said hey we don’t know what’s wrong we tried it ourselves and it worked fine! I watched the video and it literally shows them creating the error LOL :joy: I responded saying uhhh yea you just proved it doesnt work and then they responded again saying alright we’ll hand this off to a more equipped team lol.

1 Like

So found the solution from bubble support! Apparently it was a google API Key problem! It wasn’t super in depth issue as to why but from my understanding. I had an input field to input your location. My google API Keys were not setup correctly and so the location was not updating correctly and it was causing the whole listing to not work. I fixed my keys and now no issues! I appreciate your help though.

1 Like