Deleting files from the Database

I have a database setup that using a form to collect information. Part of that form is the ability to upload multiple files. Which is working perfectly well. The form is multi faceted depending on the menu button used to arrive at the form. It can be used to search the records, edit the records and add a new record. What I am trying to do, is that when it is set to edit the record, it will show in a repeating group all the files that have been uploaded to that record, and give the ability to delete each individual file. I have tried all sorts of setup to complete this task, using change a thing, delete a file, nothing seems to work, I have looked through the forum and can’t find an answer. The most annoying part is that a day or two ago, it was deleting files, but today I logged in and it had stopped and now for some reason it wont work, i even had a pop up confirmation box that worked perfectly.

Can anyone help me work this out?

Tough to give accurate advice when I can’t see the app itself (or screenshots of the workflows). I’ll try to offer some guidance on troubleshooting this though.

Have you reviewed the debugger in step-by-step run mode to see if there are any errors? What about your server logs, anything that indicates why that workflow isn’t running? As you pointed out, it was functioning a few days ago. If the debugger and logs don’t hint at anything that could be the issue, it may be a good time to see if you have a deployment you can restore from that time period when it was fully functional.

Potential causes I can think of:

  • Privacy roles limiting the deletion of files with your user account
  • Workflow, or a condition on a workflow, was modified on accident since a few days ago which is preventing deleting the files
  • URL of the file you’re requesting to delete is being stored or sent incorrectly
  • Something (like a rogue element, condition, or z-index) is preventing the file delete button from being clicked – make sure the button is at the front (right click → Bring to front), is not disabled and is clickable

One thing you can try, as a test: duplicate your file delete button (with workflows) → recreate your delete workflow as an API workflow → modify the duplicated button’s workflow to run the API delete workflow → see if recreating this functionality has any effect on your button’s functionality

1 Like

Hi Philip, thank you for your advice. sorry it has taken me a while to get back as I haven’t managed to get on Bubble for a bit. I can give you access to my app if you would like to make it easier. I am still very new and have been doing lots of googling to learn.

Solved it