Different results for 'Normal' vs. 'Slow' or 'Step-by-step'

Background:
I have a list of restaurant items (RestaurantItems) with various characteristics that I want to be able to filter for and get a subset of those items. I have a datatype “RestaurantItem” with fields like: Name (text), Allergies & Diet (list of text) etc. In this specific issue, I’m trying to filter for “Vegan” items so for each item, if the text “Vegan” is in their list of Allergies & Diet, include that restaurant item in a list, and filter out restaurant items that don’t have “Vegetarian” in the list.

My Problem:
When I run the application at ‘Normal’ status, some restaurant items are filtered out that should not be filtered out. I initially see all of the items that should be in the subset, and then about 5 to 10 seconds later, a good number of items disappear and they are no longer in the subset.

When I run the application in ‘Slow’ or ‘step-by-step’, all of the restaurant items (they have “Vegetarian” in their Allergies & Diet list) get listed I expect are listed in the subset.

My Question:
Is this a timing issue? If so how do I correct it? If it isn’t is this a bug that can be fixed?

The images show where I show the items (below) before filtering (for vegan) and after filtering. Both at ‘Normal’ runtime and ‘Slow’ runtime. Immediately after filtering at ‘Normal’ runtime the expected entire subset appears. A few seconds after, however, some items mysteriously disappear.

HI @jayborders, there is definitely some strange behaviour with repeating groups and it may be related to the one I reported a few days ago: Repeating group caches the data from a previous page (cell) before showing the pulled data!

This was thoroughly tested and was finally replicated by bubble support. I am not sure where you are located but it appears when Bubble tests these issues they don’t replicate the location of the client or take account of the latency due to CloudFront location. There is nothing worse than reporting a bug and getting a response “it worked for me” after 20 years in the software industry it is still the most annoying reponses…

My advice would be to test this thoroughly and then submit a bug report, it may be the way you have it setup but it shouldn’t do its thing while rendering the data on the screen.

I would test in all major browsers, test on both your PC or Mac and another if you can. Or even better use a service like https://www.browserstack.com/ they have a freelancer version if you have a tight budget or other services that do the same. It’s always good to get it off the development PC or Mac to test.

I know it is a bit of work, but it’s a good habit to get into so to build testing evidence and the better documented the better! No one knows your app better than you.

Hope this helps.

See below for submitting a bug report.

bubble.is/bug_report

StevenM,

Thanks for the fast reply. So far I’ve tried the following (with no progress):

  • Same browser different account (Current User) on a Mac

  • Different browser (Chrome & Safari) same user on a Mac

  • Different browser (Firefox) same user & different user on a Samsung Galaxy

I’ll try submitting a bug report as you suggested.

Thank you!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.