Forum Academy Marketplace Showcase Pricing Features

Doapicallfromserver leads to long load time?

Hey everybody,

not sure if this really slows down the site but wanted to ask if it is possible to disable this “doapicallfromserver” or change some setting so it is not executed (or does not load so long)?

My app containts API workflows btw.

Thanks and if you would like to test your website speed try https://tools.pingdom.com/

PS. All in all I am pretty content with the speed of my site.

sorry to bother you @emmanuel

But can you give me any hint on what I should change to make this go away?

Thank you!!

This is just that the service takes some time to return the response. Not much we can do about it.

thank you!

I checked several bubble-apps (from people here on the forum) with pingdom and they all don’t have that “doapicall” thing.

So, I assume it is on my side but I cannot figure out what is causing it.

I have api workflows and I connect to 2 different services via API Connector. Is the API configuration correct like this or can I uncheck this setting:

If I’m reading this correctly, it might actually be the response time from the API you’re calling through the API connector. What are the APIs you’re using?

hey thanks for your help!

the APIs I am using are all used in workflows only and never on the page itself or executed on pageload

  1. API Connector with API which fetches data from Amazon
    https://cl.ly/2q1D352r3S2c/Bildschirmfoto%202017-01-05%20um%2017.03.07.png

  2. API Connector
    This is an API I got from Nigel which converts text into numbers:
    https://cl.ly/3a350Q3Q010D/Bildschirmfoto%202017-01-05%20um%2016.58.30.png

  3. Some Blockspring Blocks

Maybe some more info from pingdom: