Drag-drop is broken

I have drag-drop implemented throughout my app. I use the app every day and pretty much take it for granted.

Today, I started working with a Mac for the first time. And by default, I’m using Safari to access my app. In testing the app, I noticed that drag-drop doesn’t work. To ensure that the problem isn’t just with Safari, I tried the app back in Windows and Chrome. No good.

I tried on my iPhone in a browser I keep open specifically for the app. Drag-drop worked. In another browser, the session required me to log into the app. I did and found that the drag-drop doesn’t work.

Based on this experience, I logged out and back in with the browser that had been kept a session live long-term and in which drag-drop worked. After logging back in, drag-drop does not work.

The behavior is that when you click on a drag area to move it, two conditional actions based on the condition “when dragitem is dragged” are activated but the object will not move.

Is this a known/recent problem?

If it matters, I’m on a Professional (legacy) plan.


I am also having the same issue. The app i’m building is based on drag and drop. Someone please resolve asap!

1 Like

Indeed, draggables are currently broken. Attempting to drag a draggable element (the cart in my picture below is a drag/drop group) throws error o[0].hasClass is not a function.

@laurence, @rosshelton file bug reports here.

:point_up_2: issue can be observed in this demo app of mine

I’m also on Legacy if that matters.


1 Like


Having same issue here! Please fill us in on a fix if you find it!

This is the automated response:

Hello, Thanks for reaching out! Please note that our work hours are Monday-Friday 9am-6pm EST. This inbox is monitored for emergencies outside of our work hours, and our team will get back to you as soon as we are able, generally within 1-2 business days. Thank you!

@rosshelton @raymondgregorymusic @keith

I must say I’m not happy with this kind of “support”.

@josh @eve Hopefully one of the partners reads the forum.

We’re on it – sorry guys


Seems to be back working! :grinning:

Yep, fix should be live

1 Like

Thanks @josh for the quick fix!

thank you, @josh!

Thank you.

This topic was automatically closed after 14 days. New replies are no longer allowed.