Dropdown not accepting input

Hello, Im running into issues with the dropdown element. The data works and it is able to pull the representatives. However when I click on them, the value does not populate. I have tried playing around with the padding and sizing but that has not worked. Help please.

I believe it’s because you’re setting your default value to be the first item, so no matter what you choose you will always get the first item. You need to change that value to reference your value saved to the table. If this is not being stored to a table then reference a custom state instead.

I removed the default value entirely, but I am experiencing the same issue.

for reference

How does the workflow look like for the dropdown?

There is no workflow? Should there be?
Here are the default conditions.

But I have elements & data on the page dependent on the value in “dropdown representatives”. So that is what is effected by the dropdown value.

Arent you trying to do something when dropdown value changes?

I’ve set the main group’s data to be the value of the dropdown. And the sub-group’s data, text data, and chart data is set to “parent data”. That is what changes with the dropdown value.

Interesting. I have tried many things on the page but couldn’t figure that out. Maybe put another dropdown just next to it, with the same source and everything. And don’t change anything then the basic data stuff, To make sure, a regular dropdown works.
image

1 Like

Interesting, the new dropdown with nothing dependent on it, works.

I am finding that because the Main Group (which the dropdown element is in) has its source set to the value of the dropdown, the dropdown value will not accept.

My solution is to remove the dropdown from the Group altogether. A bit of a bummer from a design perspective, but maybe there was some infinite loop or something broken in the data.

1 Like