Forum Academy Marketplace Showcase Pricing Features

✉ Sendinblue SMTP A free alternative to Sendgrid mails by Reduble.com

@theo.voglimacci1 , @fcastillosa.apps , hello.

Let us please check your requests. We will get back to you as soon as we have any useful info on the issue you’ve faced. Please be patient, because some delay is possible due to the weekend.

Regards,
Zeroqode Team

Hi @ZeroqodeSupport,
I have just updated the plugin, and now I have two issues:
1/ on one workflow, I seem to have the same issue as @theo.voglimacci1


2/ on another workflow, the email is sent, but without the parameters.
What did I do wrong ?
Hope you can help me !

EDIT: found the answer for 2/: parameters now have to be formatted this way {{params.name}} for a name instead of %name%

Still need some help for my first problem, though !

@theo.voglimacci1 ,

Okay, thanks for the clarification. As your error massage states, your input should be a valid JSON object. This error refers to the incorrect Sendinblue - Send SMTP Mail + Template body field value. Instead of the email value, you have typed a sender name:


Please try to type there a valid email address and try again.


@fcastillosa.apps ,

The Sender name parameter should be configured in your Sendinblue parameters tab, this is not the part that the plugin can influence. Please check the https://my.sendinblue.com/advanced/config:


@marie ,

Please check the correctness of the (body) body parameter. Also please check the screenshot of your troublesome action, to make sure the issue is not caused by the incorrect body parameter.

Thank you, friends, for your patience and understanding.
Regards,
Zeroqode Team

I see, some " were missing :slight_smile:

1 Like

Hello,
I have the same problem. Have you found a solution @fcastillosa.apps ? @ZeroqodeSupport any idea to personalize the sender’s name. Even when I configure Sendinblue, I always have the email that appears in the sender’s name.
Thx :wink:

Hi @killianAB , it never worked out for me. I think that something is wrong with the plugin. However, I found another way to do what I wanted (that was sending a welcome message). I just followed what @lucie told me to do on this thread [New Plugin] Sendinblue Contacts - #15 by fcastillosa.apps and then I created a welcome message automation in sendinblue. It is working beautifully and messages are being sent directly by sendinblue’s order not through any API, so the email gets sent with the exact parameters that you set it up in sendinblue (including the senders name).

1 Like

Thank you @fcastillosa.apps
That’s the way it works. I used" the automation part of Sendinblue and it’s perfect!
Thanks again :+1:

1 Like

@fcastillosa.apps ,

Apologies for providing not helpful suggestions regarding the sender name question. The actual sender name can be configured on the Sendinblue side, as I have said.

When you are creating a new template in Sendinble, there are 2 fields “from Name” and “from Email”. They are containing the info on the currently created sender. You can add a new sender and verify it, f you want:

Still, I’m glad you have found the workable solution for you. :slightly_smiling_face:

Regards,
Zeroqode Team

Hi,
I have a problem with JSON, one email didn’t leave because of a " in the email.
Is there a workaround ?


The first " mark the JSON object “product name” but the second are just what my user placed in the product title.
Thanks a lot !

Hi @marie, thanks for the question.

The " " marks used by the user to limit the product title are conflicting with the message body, which even if is transmitted through HTML, still comes through JSON format.
That would mean that use of the double " mark changes the JSON request itself.

To avoid the above-mentioned error, please advise your user to use the ' ' marks for limiting the product title.

Hope it helps.
Regards,
Zeroqoe Team

1 Like

Hi @ZeroqodeSupport ,
Have tried this like others users but nothing happens for the sender name. Keep appearing the email when sending with the plugin.
Did a test directly from my sending blue account and sender name appeared correctly.
Any way you could look this into detail and give a solution please?

Hi @jorge.delcarpio1985, thanks for reaching out.

Let us please check this from our side again.

Regards,
Zeroqode Support

@jorge.delcarpio1985 ,

If you use the Send Email action, there is a Sender Name field - Screenshot by Lightshot. It works with no issues on our site - Screenshot by Lightshot.

If you use the Send Email + File action (Screenshot by Lightshot), it works well too - Screenshot by Lightshot.

You need to insert a sender name into the body parameter into the Send Email + File and Send Email + Template actions the way I show you here:


I recommend using some JSON validator as it is more convenient to customize the JSON body parameters in there and validate them, than just typing into the “body” field. (this for example https://jsonlint.com) :slightly_smiling_face:

Hope it helps.
Regards,
Zeroqode team

Can we use this plugin to send file attachments using base64 and without file url?

Hi @shu.teopengco, thanks for reaching out.

Sure thing you can. To do so, please follow the supporting documentation (namely p. 3. Send SMTP Mail + File)

Hope it helps.

Regards,

Zeroqode Support Team

Thank you! :slight_smile:

1 Like

Hello bubblers and @ZeroqodeSupport Team!

I’m facing an issue and I can’t really figure out if it’s on Bubble’s side (a bug or something like that) or the plugin’s side.

I have list of documents which I want to send by e-mail (one specific at a time) to some people with an Endpoint for the Sendinblue SMTP plugin.

When I try to do it with a totally new doc (doc created by the user with name, text, etc) it works perfectly. But when I “duplicate” the contract (using a reusable element and an workflow to create a new doc with the information of the previous one), it just simply doesn’t trigger the Sendinblue endpoint (all the other Bubble actions work).

I’ve downloaded the CSV, compared all the values from the 2 objects and saw that the information are identical. Only the “create date”, “modify date”, “unique id”, etc are different, but because they can’t be the same :sweat_smile:

Can someone give a hand, please?

Hi @luiz1 , thanks for reaching out.
Allow us to check the reported issue and see for a possible solution.
We will come with feedback in a due course.

Regards,

Zeroqode Support Team

1 Like

Hi @luiz1, thanks for your patience.
Apologies, but on some examples it would be much easier for us to understand your user case. Would you kindly share the details of your setup and use case (screenshots)?

Also, please note that unfortunately, the current plugin functionality doesn’t allow sending emails to a list of users, only one by one (that is why first mail is sent and following are not). Sorry for the inconvenience.

Regards,

Zeroqode Support Team

Hi team, thanks for your quick reply!

Sure, you can see below the screenshots.

In regards to the list of users, I was aware of that. The endpoint was scheduled to work on a list to surpass this issue. Thanks anyway for the comment!

1 - This is the reusable element used to duplicate docs…

… and its workflow. As you can see, it’s really simple.

2 - The reusable is used in a RG to, among other actions, to “duplicate” the doc (as text, it does not create a pdf).

When I create a doc from scratch without duplicating it, and call the API endpoint on a list (below), it works fine. But when I try to do the same thing with a duplicated doc, it just simply ignore the API call.

The process is the same, with the same values (exception of Unique ID, etc), but when and only when I duplicate the doc, it doesn’t work. The only variables that are NOT the same are the ones below. All the other ones are exactly the same.

Hope it helps!

In the meantime, I just took the “duplicate” option off :stuck_out_tongue:

Thanks a lot!