Forum Academy Marketplace Showcase Pricing Features

Enable input takes too long and focus fails

I’ve got a dropdown and an input next to it. The input is disabled until the user selects something from the dropdown.

A trigger for “when dropdown changes and the value is not empty” starts a workflow that just sets the focus to the input. The input itself has a condition where it will be enable if the dropdown’s value is not empty.

If I run the page with the debugger on, step-by-step, whenever I select from the dropdown it immediately enables and focuses the input. If I run the page without the debugger, then the first time I select from the dropdown it does enable the input but doesn’t set the focus. Every selection after that does set the focus properly. Additionally, if I set the dropdown back to the empty option, the input disables as it should. If I then make a new “first” selection the input is again enabled but not focused.

Maybe the messages are firing off with the wrong timing? Like if the input is disabled it’s still disabled when the focus tries to set, so the focus fails. After that the input is enabled, so when the focus sets it works. Then when the debugger slows things down it doesn’t have the timing problem.