Eternal loop and no saving to database?

Hi there!

I have been around for some time but have a issue I haven´t seen before.
Probably I´m too frustrated to find the error right now, so I reach out to you folks.

I´m fetching a datalist via API in one API workflow endpoint (triggered by a POST via API)
In that endpoint I schedule workflow on the list, to get each row as a single data.
In another endpoint, which is called to be scheduled, I save the different parameters to database.

When I trigger the endpoint to schedule, it is scheduling each row as it should with correct values, but … forever it seems. The datalist is 38 rows but it looks like it is looping.

The other problem is, nothing is saved to the database.

So I need a couple of fresh eyes to help me look at this to help me.

Here´s screenshots:


Here´s a link to my app if someone wants to check something out.


@idealabs As long as the list is finite, it shouldn’t loop. Do you have another workflow that schedules itself? Are there any privacy restrictions on Product thing?

1 Like

Hi Neerja!

Thanks for the ideas!
Yes, the list is 38 rows and will not be longer if I dont make a change to it. No other workflows at all actually.
No privacy restrictions neither.
No errors in the log etc.

Strange, isnt it? :thinking:

@idealabs One last check, if there is no ‘pause scheduler’ enabled, then please submit a bug report

Hi! I just tried once again. I had set the count field of the api to ignore in the API call. Thats the only thing I changed back and now it works. Don´t know if that makes this issue. The count field of the API call is outside the actual data list.

I also got a message from shot about an outage on the Bubble servers while I was running my app, it could maybe be the problem?

Bottom line, it works! Cheers!

1 Like