Filter RPG with custom state or multiselect

Hello I am trying to create a filter for a social feed and I have tried using multiselect and now on custom states. I have tried multiple ways to get the filtering done with the custom state list but when I go into the List Filter’s Advanced function I cant get any condition to stick. Any advice would be great!

Attached is a picture of the filter/advanced function and the custom state list showing the list works when selected.

What I am trying to do is for the items add to the custom state list, I want them filtered out of the post feeds. Thanks!
Picture2
Picture1

Hi there, @allen.archuletajr… if I understand your post correctly, give this filter a try and see if it produces the desired result.

Advanced: This Comm Post's Post Mood is not in app's Mood Filter

Hope this helps.

Best…
Mike

Hello @mikeloc I tried what you recommended and it is still red and not taking. I’m so stumped by this.

Is the state type of the custom state the same as the field type of the Post Mood field? What does the issue checker say?

@mikeloc If I am understanding your question correctly, yes. The post moods are options and I am using the following custom state workflow to trigger the filter. Here are all the steps I have taken for your review.


Picture2
Picture3
Picture4
Picture5
Picture6
Picture7
Picture8

@ccabaj I know you helped with another similiar post. I tried to use your feedback in that post but it got a little confusing trying to merge the two. Please feel free to provide any feedback you might have.

The custom state is on the app element, and the state is called Mood Filter, but you aren’t referencing that element and state in your filter. Unless I am missing something (and I almost certainly am), you should be able to set it up literally the way I typed it in my initial response.

@mikeloc I am pretty sure I showed all the steps in the pictures. Did I make a mistake somewhere? I am very new to using custom states.

In your last screenshot, did you try setting up the filter the way I typed it in my first response?

Like this…

Yes and it didnt take it.
Picture9

If you want to share a link to your editor (privately) and let me take a look under the hood, I’m sure we can get it sorted out.

sure that would be great. Thank you for helping me with this.

1 Like

FYI for the thread and maybe for @ccabaj (who was tagged in one of the responses)… as I suspected, it looks like the issue was a type mismatch between the field in the data type and the custom state.

Hi there. It looks like you are now sorted from help by @mikeloc ? Is that correct @allen.archuletajr?

Yes we got it all figured out thank you!

Great to hear. Feel free to tag me if you need help in future.