:filtered / :contains Not Working

I have a situation in which repeating groups aren’t working as intended when using the :contains within :filtered.

The left repeating group searches for a list of (essentially) users (UsPus).


The first text box displays the users name and the second text box displays whether a numeric range that belongs to that user contains the numeric range in the dropdown above.

“Net availability mon” is a list of numeric ranges e.g. [60,120] , [75,135] , [90,150] etc. just for context these numeric ranges represent time from 00:00 in minutes but I have changed the option caption of the dropdown to show the :min value formatted in 24-hour time e.g. [90,150] would be 1:30.

The dropdown lets you select one numeric range that would be the same as one of the ones in “Net availability mon” e.g. [90,150]

In this instance, 6:00 ([360,420]) is selected and the left repeating group shows that “Bobby”'s “Net availability mon” also has [360,420] in his list of numeric ranges.

The right repeating group searches for UsPus (no constraints) and then filters them using the same expression used in the right text box in the left repeating group however the right repeating group does not display any UsPus despite the left repeating groups saying that it should.


Just curious on the right repeating group do you have any constraints on the search? Just making sure there isn’t a constraint on the search and a constraint on the :filtered operator

None.


Just as test in the :filtered add a constraint “Advanced:” and flip the operation around, so it’s “Dropdown select time’s value is in This UsPu’s Net availability Mon”

and remove your current constraint

1 Like

Your suggestion worked even when using the same statement but with advanced in front of it!

I didn’t know advanced was a thing. What makes advanced different to using the same statement without it?

Thank you so much!

1 Like

Yea I’m not too sure. What I like about the Advanced: is you can do really complex statements and it allows you to reference “This [thing]” which you can’t normally use. It’s only available in the :filtered operator and not in the constraints section in a search

2 Likes

That is really cool. Time to do some playing around with it.

Did this suddenly stop working? Or is this something new you’re working on? I ask because I’ve been chasing down a similar problem that worked great before. Now suddenly it just stopped working.

It’s running fine on the live version. But It stopped working on the dev side.

Yep like one time I had to compare two lists and if at least 1 matched in each list it would show the item, so I used the filtered: Advanced: This Item’s things intersects with Current invoice’s things:count > 0. Pretty powerful stuff.

Keep in mind the :filtered action is a client side operation so Bubble recommends using the Search constraints to narrow it down as much as possible on the server before having to download all the results, but sometimes nothing you can do you have to use the :filtered only.

1 Like

I figured it out. On a whim I selected the 8/22 “experimental features.” Well… They don’t work!

Yea experimental stuff is breaking my app like crazy. I’m staying away from stuff unless I desperately need it like the “Expression parentheses” feature.

It’s just something I’ve been working on; I just made it yesterday. Also, the only experimental feature I have turned on is parentheses.

This topic was automatically closed after 14 days. New replies are no longer allowed.