Filtering by date bug?

I have a image that was created two days ago (OCT 15th) and i’ve made some filters on a repeating group to grab all the photos in the past 7 days, not including today:

Which should be finding the image from the 15th, yes? but it’s not :confused:


  • if i delete the last filter ( < ) then the photo does show up
  • i have other similar filters for today, last month, year, etc. which all appear to be working fine

You are asking it to look for current date and time, so if you uploaded the image on the 15th BEFORE now’s date then it wouldn’t find the image.

You need to use the :change hours to 0, :change minutes to 0 and change seconds to 0 on the current date to take out the time (i.e take the timestamp back to 12 am on that date)


Absolutely what I was thinking.

You could also consider using a specific timezone for your app (UTC for example). This way you can ensure that the ‘Created Date’ value and Bubble’s ‘Current date/time’ operator use the same timezone, standardizing things all across.

1 Like

woww just blew my mind lol… thanks!

okay that working… kinda… i have a few different repeating groups and it’s working in all but this one:

  • If i use this filter as-is (“greater than” 1440 seconds ago), the image it doesn’t show up (uploaded less than 20 mins ago)
  • if i flip it from “greater than” to “less than” then it shows me the list of images without the one i just uploaded

what the heck lol

Go re-read my above post again :wink:

1 Like

I’ve done that like 5 times, thanks… Here’s what i have now, based on another post i found in bubble as well as your reply above:

but still it doesn’t show up :confused:

That wasn’t the constraint you had in your screenshot.

I can’t debug your app for you. All the information you need you have available for you.

Check your data against your logic, check your privacy rules etc, check your data sources…the answer lies in there somewhere. It’s your job as a dev to be able to troubleshoot that. If it’s working in your other RE’s then its not the logic that’s the problem, its a set up in your RE somewhere. Go chase it down.


I appreciate your help! :slight_smile: …and i do get what my role is here (been bubbling for years now)… and assuming i’ve got the expression filter right this time, my point is the following:

if this:
is pulling up yesterday’s image (using “less than”)

then using the opposite operator (“greater than”):

should pull up today’s image, yes? (i’ve tried both “equal-to” and “greater than”)

I’ve been trying to figure this out since your last reply, and everything i’ve tried isn’t working so im just not sure what else it could possibly be :frowning: i orginally thought it could be a bug (silly me, should’ve started in a different category)

but where do i go from here? there aren’t any other filters/privacy rules/or show/hide elements (that i’ve been able to find) blocking this group from appearing…
i’d be happy to duplicate/recreate the page for you or anyone else who’s interested in assisting me :slight_smile:

Thanks again!

Heyyy, yeah… so you were right! ~3 hours later into looking over my elements, workflows and conditionals, i realized i repetitively overlooked a conditional: had the parent element of that repeating group set to only show if the count was greater than 1 (instead of greater than 0) :man_facepalming:

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.