Find & replace doesn't seem to be working

Hi, I’m trying to replace automatically “->” by “→” in my app.
So I’m using a database trigger event that fires each time the content is modified and checks if the content has the “->” characters and replaces it.
But for some reason, it doesn’t seem to work.
Any idea why?


Try it without the “Only when” condition on it and see if it works. Maybe the contains operator isn’t finding the “->” if it is part of a word or something…

@tylerboodman good point. I tried without the condition and it’s still not working…

Hmm… :thinking:

1 Like

Is the change in your database actually being made for it to trigger? Like clicking out of the input box with autobinding enabled

Also you could try a “When condition is true” (everytime) event on your page, and just have it monitor the thing with the same condition, it might be faster

Actually, I’ve had this issue as well yesterday with a backend workflow.

I was trying to :find&replace a few things but didn’t work as well.

I didn’t investigate that much at the time, but it may be a bug ?

@tylerboodman you gave me the idea to actually go look in the database at what was happening. And the :v: funny :v: thing is that my “->” characters were actually saved as something entirely different. I’m using the light RTE plugin w/ autobinding and I guess it changes the characters…
Anyways, I’m now looking for -> and it does work!
So thanks!