Fuzzy Search & Autocorrect + Custom State

Hi, all!

My Fuzzy Search doesn’t work with a custom state. I have a RG of Data Type ‘Student’ and I need to sort it by name using a workflow. To do so I set a custom state on the page (of type ‘Student’, a list), and the Data source for the RG is this state. So that I set the state through the workflow and the RG’s Data source changes accordingly. Initially I set the state ‘Search for Students’ when the page is loaded. Then, when the input ‘Search by name…’ is changed, there are 2 steps:

  1. set the state ‘Search for Students’
  2. set the state ‘Search & Autocorrect’s Matches’ (only when the input’s value is not empty (I also tried ‘Search & Autocorrect’s input box’s value is not empty’ - same result)).
    So the problem is that 2nd step doesn’t seem to work - nothing happens.

If I trigger the search using a condition, it works just fine (see page ‘fuzzy_conditional’). Also, this type of workflow works perfectly well with a Multidropdown (see page ‘multidropdown_custom_state’).

I attach the link to the demo app:

Pinging @ZeroqodeSupport for visibility.

1 Like

Hello, @snowstorm. Thanks for using our plugin.

First of all, can you please tell if the same issue is reproducing on the latest plugin version? At the moment you are using the 14th version.

If you prefer to use the 14th version, try to use “Search & Autocorrect Input Box’s Value”, instead the Input Search element in your “Only when” event here:


Please try the suggested and let us know how it goes.
Zeroqode Support

Hello, @ZeroqodeSupport. Thank you for your fast reply.

I’ve tried the later versions and now in works in terms of showing search results. Although there seem to be 2 other problems:

  1. results are only shown when I click outside the input;
  2. when I clear the input, the repeating group doesn’t get reset, it only shows the latest search results.

So I wonder if I should set it up differently.


We have reviewed the reported issues with our Fuzzy Search plugin and have not encountered it on our test app. However, please find below a link to the test use case setup which may help you resolve the issue:

Please follow the provided use case setup.
Hope it helps! :slightly_smiling_face:
Zeroqode Support