Fuzzy Search: Search for Items that a User owns

Hello,

I’ve Items and Users.
A User can own Item(s). (That is working)

I’ve implemented the Fuzzy Search and it worked for Data Source: Search for Items

But now I only want to Search for Items that a Current Page User is Owning.

I tried:
Data Source: Current Page User’s ItemsOwned

But when I type something into the search, there are no results.
Bildschirmfoto 2022-07-06 um 18.12.13
Bildschirmfoto 2022-07-06 um 18.12.38

Also I tried Search for Item and tried with “Constraint” but this is also not working.

Thank you for your help!

Hello, @freund
Thanks for using our plugin.

Please allow us to add some highlights regarding this plugin’s setup.
Note that the Repeating group Data Source = the database table on which you are doing your search. It means you should indicate the Do a search for database table name as a Data Source of your Repeating group.
As we can see on your screenshots, you have set as a Repeating group Data Source - the reference to the current user’s items, that is not correct.

However, you can play around with the constrains for the main Data Source. As an example, you can try using “first item” instead of “each item’s name”, since you already using field “name” in the field to search.

Please try it and let us know about your result.
Best regards,
Zeroqode Support Team