Getting lost with forms in app

Hi Team
OK Building my first app - a proposal app for small business similar to Quotient- this is primarily to help me - I run a small MSP and spend too much time doing proposals, I want to speed it up and also make it look nice and simple- but also as a side gig. Have been learning Bubble, watching the videos, dreaming about it…sad I know :joy:… but am now a wee bit stuck!
I am creating a form so that signed up users can enter content that will then create the proposal for them but cannot get two things to work:

  1. I cannot get the rich text editor to expand as content is out in, once I go over it it goes blank
  2. How do I add a new item or indeed an optional item - I will add a checkbox and workflow afterwards in eth proposal template for people to check but I cannot for the life of me figure it out. have tried many many ways to no avail.

I have been building the app functionality based only just now and will make it look pretty afterwards - maybe not the best way I know but I need to get it working first, so don’t judge! :stuck_out_tongue_winking_eye:
Picture below to help

Hey Mark,

Both of your questions don’t really make sense. Are you saying that when you add text to the rich text editor, and the text is more than can fit in the visible space, it just disappears?

Also, regarding adding an item, do you mean you don’t know where to begin?

Consider a repeating group if there is the ability to add more than one. If you can only add one, then just a field in that record (datatype).

Let me know,

Hi Benjamin

yes having a bit of trouble explaining it…OK
Rich text, yes I want the rich text to expand if they go over the limit, just now the minute I type on letter more than it can take it goes blank and the text is lost.

the second problem is more a “how do I set it up” What I want to happen is that every time a user clicks the add new item button it will add a new record to the proposal that is recorded. So they may keep it at one line or 10 lines that are all recorded and then totalled up later.
I tried repeating groups but could not get it to work.
Hope that is better explained!

This topic was automatically closed after 70 days. New replies are no longer allowed.