Google Maps API (Stopped Working)

Okay, I appreciate I have posted about this a few times now but yet to find a solution. I have tried my best troubleshoot the problem but am yet to find a solve.

What’s frustrating is that it only ever worked intermittently. Sometimes it would display a time, others it would be blank. Now it doesn’t work at all.

Data call:

Database entry:

Debugger:

Rows and Elements Empty

Duration text also empty

If anyone has any ideas I would really appreciate some guidance.

Hi,

Have you tried to put longitude, latitude for origin and destination in your API call ?
I usually do that and don’t have any problem…
Best
Matt

Also, what is the error that you see? There is a red icon

Good guess, but not sure that’s it. I’m able to use it without latitude and longitude and it works just fine.

Curious to see the errors as well…

1 Like

@mattmazzega @emmanuel @dan1

I made changes to the API call one by one and have discovered the cause appears to be the missing input for departure.

Everything seems to be working fine now.

You guys throwing ideas out there make this all a little more bearable, thank you.

SOLVED.

1 Like

Good catch! I’m wondering - does the plugin autofill “now” and had you deleted it? If not, it may be a good optimization for @AliFarahat to incorporate in his update.